summaryrefslogtreecommitdiff
path: root/dev-python/dj-database-url/dj-database-url-1.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-13 21:28:20 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-13 21:28:20 +0000
commitb9d995791a762215ef1ced2cc1a47b8d3c2cff1a (patch)
treeceff6a3b47b9258682735a5595c9ee8a0427a445 /dev-python/dj-database-url/dj-database-url-1.2.0.ebuild
parent50098d976449286058396cebad0087e28f771b90 (diff)
gentoo auto-resync : 13:12:2022 - 21:28:20
Diffstat (limited to 'dev-python/dj-database-url/dj-database-url-1.2.0.ebuild')
-rw-r--r--dev-python/dj-database-url/dj-database-url-1.2.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/dj-database-url/dj-database-url-1.2.0.ebuild b/dev-python/dj-database-url/dj-database-url-1.2.0.ebuild
new file mode 100644
index 000000000000..c30f6849ca02
--- /dev/null
+++ b/dev-python/dj-database-url/dj-database-url-1.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Use Database URLs in your Django Application"
+HOMEPAGE="
+ https://github.com/jazzband/dj-database-url/
+ https://pypi.org/project/dj-database-url/
+"
+SRC_URI="
+ https://github.com/jazzband/dj-database-url/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest