summaryrefslogtreecommitdiff
path: root/dev-python/distlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/distlib
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/distlib')
-rw-r--r--dev-python/distlib/Manifest6
-rw-r--r--dev-python/distlib/distlib-0.2.1.ebuild27
-rw-r--r--dev-python/distlib/distlib-0.2.4.ebuild53
-rw-r--r--dev-python/distlib/files/distlib-0.2.2-unbundle.patch35
-rw-r--r--dev-python/distlib/metadata.xml13
5 files changed, 134 insertions, 0 deletions
diff --git a/dev-python/distlib/Manifest b/dev-python/distlib/Manifest
new file mode 100644
index 000000000000..fee6ce7f65d4
--- /dev/null
+++ b/dev-python/distlib/Manifest
@@ -0,0 +1,6 @@
+AUX distlib-0.2.2-unbundle.patch 1284 BLAKE2B 994f1d3e035273bbeb0f8aec357a7ea62188d515ef7e951b773f8a87aeede8081a6e59928748961ed1e7b569212ab4521dafcf7d7f1fea5d9eec14ba7ebef678 SHA512 90ae9177e09a4ae23a5e1a90e5599602466ede4b9fc2b19024c00a187f7393fc2fb84795bf5bb699bdbe071a97514bf86e8da556c8cacb49db0985f2ed8fe18c
+DIST distlib-0.2.1.zip 542424 BLAKE2B 241b14519499b76beaa8994b30be8b78ea83f3073668174f4e2e02cc9609feb957b3b4fdb59e68943223e6fb8d0251a8bab990396c4e4297c683ab4eda8fbcc9 SHA512 f6453585650db242ad4a176bbd468cc6069ee0941b6ea23f24fc32000778097d8a100de82eaad7b3d8d998dc153d25f537505c7eefcc6f98f37995cfc9d5be77
+DIST distlib-0.2.4.zip 547411 BLAKE2B 763027059faccdcee682d5eddbdeb2c23cfefff178d992db811233b48d7a4d605626f8619d51dacc55ae5a016557e528b0bec0c625258e469f2fd98a9a659c6b SHA512 03f9f9474578226e1a40a85a490aead3ec0509ba444856a263d4f25b3c86b5f919a3e18ff715a3a329d80a3f20a540b8c57a6e3dff55703c9cce730e2d021084
+EBUILD distlib-0.2.1.ebuild 717 BLAKE2B 3e8ae24ebe56cd39197fd22ff270a71d971395f34d992b66a3ec054a1ab2f331380bbab24f3c40e94516ab2afbfa9afe6a11e70176c0ee30c0b1d07b4f4bbb82 SHA512 3d7f9e68799de98f46005f988b7b9bdcd637665f6a128e35b69a5cf9d3002730de7c9021bcddc05c3e45a0453a08142aa07700f285b2f8a1735dc53a96079436
+EBUILD distlib-0.2.4.ebuild 1249 BLAKE2B c40e578c367854e2cd1b4d5c627de63ec32527d5b544452a08b4784e2d2b0a2badaa9871c262813a0b30bdb6d92b99739a6123863811382889c92a5b0c4ccc4e SHA512 227df3b6e29f53ec055f90c01fb23e449f71be1ee34925a6a1427da4a85e06ed499915d9786fa8577e821c2ac2e5634e3d7c84e641f2cbdf4e558d0a9d1fb01d
+MISC metadata.xml 426 BLAKE2B 58e513afff4bb2079ab3bf04944f3e0bfda90793443637b200eb3f52758f0ad15c8ef742d70724d368901382af2f6cf6fd4e8367d43f3afc43f9a7fa42bd1480 SHA512 08bab081b7287399834521ed7f3bad016a3c0be3b7b191875e23b4cb0577afc02ae9d553de80552212852ceb473a4ca424efecf226826eea80461a3fb028a36e
diff --git a/dev-python/distlib/distlib-0.2.1.ebuild b/dev-python/distlib/distlib-0.2.1.ebuild
new file mode 100644
index 000000000000..df75b4c73260
--- /dev/null
+++ b/dev-python/distlib/distlib-0.2.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Distribution utilities"
+HOMEPAGE="https://pypi.org/project/distlib/ https://bitbucket.org/vinay.sajip/distlib https://github.com/vsajip/distlib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+
+python_test() {
+ sed \
+ -e '/PIP_AVAILABLE/s:True:False:g' \
+ -i tests/*py || die
+ PYTHONHASHSEED=0 esetup.py test
+}
diff --git a/dev-python/distlib/distlib-0.2.4.ebuild b/dev-python/distlib/distlib-0.2.4.ebuild
new file mode 100644
index 000000000000..2739e18ac59e
--- /dev/null
+++ b/dev-python/distlib/distlib-0.2.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Distribution utilities"
+HOMEPAGE="https://pypi.org/project/distlib/ https://bitbucket.org/vinay.sajip/distlib https://github.com/vsajip/distlib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.2.2-unbundle.patch
+)
+
+python_prepare_all() {
+ rm -r \
+ distlib/*.exe \
+ distlib/_backport \
+ tests/test_shutil.py* \
+ tests/test_sysconfig.py* || die
+
+ distutils-r1_python_prepare_all
+
+ # Broken tests
+ # 1 fails due to it being sensitive to dictionary ordering
+ # inconsistency between code and test
+ sed \
+ -e 's:test_dependency_finder:_&:g' \
+ -i tests/*py || die
+
+ # Gentoo still doesn't report correct ABI
+ sed \
+ -e 's:test_abi:_&:g' \
+ -i tests/*py || die
+}
+
+python_test() {
+ sed \
+ -e '/PIP_AVAILABLE/s:True:False:g' \
+ -i tests/*py || die
+ SKIP_ONLINE=True PYTHONHASHSEED=0 esetup.py test
+}
diff --git a/dev-python/distlib/files/distlib-0.2.2-unbundle.patch b/dev-python/distlib/files/distlib-0.2.2-unbundle.patch
new file mode 100644
index 000000000000..5ee912905602
--- /dev/null
+++ b/dev-python/distlib/files/distlib-0.2.2-unbundle.patch
@@ -0,0 +1,35 @@
+--- distlib-0.1.9/distlib/compat.py.orig 2014-06-06 09:58:21.317560756 +0200
++++ distlib-0.1.9/distlib/compat.py 2014-06-06 09:58:29.955611427 +0200
+@@ -17,7 +17,7 @@ if sys.version_info[0] < 3:
+ from types import FileType as file_type
+ import __builtin__ as builtins
+ import ConfigParser as configparser
+- from ._backport import shutil
++ import shutil
+ from urlparse import urlparse, urlunparse, urljoin, urlsplit, urlunsplit
+ from urllib import (urlretrieve, quote as _quote, unquote, url2pathname,
+ pathname2url, ContentTooShortError, splittype)
+@@ -267,7 +267,7 @@ except ImportError: # pragma: no cover
+ try:
+ import sysconfig
+ except ImportError: # pragma: no cover
+- from ._backport import sysconfig
++ import sysconfig
+
+ try:
+ callable = callable
+--- distlib-0.1.9/setup.py.orig 2014-06-06 10:19:13.971997156 +0200
++++ distlib-0.1.9/setup.py 2014-06-06 10:19:20.012034150 +0200
+@@ -62,12 +62,7 @@ distutils.core.setup(
+ platforms='any',
+ packages=[
+ 'distlib',
+- 'distlib._backport',
+ ],
+- package_data={
+- 'distlib._backport': ['sysconfig.cfg'],
+- 'distlib': ['t32.exe', 't64.exe', 'w32.exe', 'w64.exe'],
+- },
+ cmdclass={
+ 'test': TestCommand,
+ },
diff --git a/dev-python/distlib/metadata.xml b/dev-python/distlib/metadata.xml
new file mode 100644
index 000000000000..f095796ff078
--- /dev/null
+++ b/dev-python/distlib/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">distlib</remote-id>
+ <remote-id type="github">vsajip/distlib</remote-id>
+ <remote-id type="bitbucket">vinay.sajip/distlib</remote-id>
+ </upstream>
+</pkgmetadata>