summaryrefslogtreecommitdiff
path: root/dev-python/discogs-client/discogs-client-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/discogs-client/discogs-client-9999.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/discogs-client/discogs-client-9999.ebuild')
-rw-r--r--dev-python/discogs-client/discogs-client-9999.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/dev-python/discogs-client/discogs-client-9999.ebuild b/dev-python/discogs-client/discogs-client-9999.ebuild
index 36b9175dec97..2ca0f4090ab6 100644
--- a/dev-python/discogs-client/discogs-client-9999.ebuild
+++ b/dev-python/discogs-client/discogs-client-9999.ebuild
@@ -1,25 +1,24 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
-
inherit distutils-r1
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/joalla/discogs_client.git"
inherit git-r3
else
- MY_PN='python3-discogs-client'
- MY_P=${MY_PN}-${PV}
- SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="mirror://pypi/p/python3-${PN}/python3-${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/${MY_P}"
+ S="${WORKDIR}/python3-${P}"
fi
DESCRIPTION="Continuation of the official Python API client for Discogs"
-HOMEPAGE="https://github.com/joalla/discogs_client https://pypi.org/project/python3-discogs-client/"
+HOMEPAGE="https://github.com/joalla/discogs_client
+ https://pypi.org/project/python3-discogs-client/"
LICENSE="BSD-2"
SLOT="0"
@@ -30,4 +29,4 @@ RDEPEND="
dev-python/python-dateutil[${PYTHON_USEDEP}]
"
-distutils_enable_tests nose
+distutils_enable_tests unittest