summaryrefslogtreecommitdiff
path: root/dev-python/dirty-equals
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-01 19:24:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-01 19:24:10 +0100
commitb052fbf151106a4f47cac7fdf0ffff983decb773 (patch)
tree5d21279a4eeaf4076caee87654b610a0fe8a4051 /dev-python/dirty-equals
parentc3b55a6be7da027d97d8aef00ef88c3011121a42 (diff)
gentoo auto-resync : 01:09:2022 - 19:24:10
Diffstat (limited to 'dev-python/dirty-equals')
-rw-r--r--dev-python/dirty-equals/Manifest2
-rw-r--r--dev-python/dirty-equals/dirty-equals-0.5.0.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/dirty-equals/Manifest b/dev-python/dirty-equals/Manifest
index c1b3cff6a6be..71835ae19879 100644
--- a/dev-python/dirty-equals/Manifest
+++ b/dev-python/dirty-equals/Manifest
@@ -1,3 +1,5 @@
DIST dirty-equals-0.4.gh.tar.gz 41864 BLAKE2B 0b916d37b323e9f587a977b46415432bc11367a6d0c95ac49e47fe604b3ee16c26eaecbbe74464076834c6186f5f0eecc049b211699a3f515ef7fdadc492537a SHA512 f98fa8c9850f26efc44dc2c5cc0ea6d687c07b49980c3eeaa71eaae78930e418c03bb35cb88aab065905443fa354b9b05d44a588458ed37d140d376b943c9da9
+DIST dirty-equals-0.5.0.gh.tar.gz 44684 BLAKE2B ccd0d4e254a529e2b3d1014390d3e21a869e145fc0d9913e01e896ce103d853315d496264fdf611aa1fded8c66673bcb9e38dc41984ebfc566a9621b99240f81 SHA512 5d89105e3eb4e3dd52423aafed6c3ddf50890cfb3c03623723d0ab79f9814e892ba91cf789fa495ecc663b03c49516687fc2c1bc548816d60ade4f64df561ab9
EBUILD dirty-equals-0.4-r1.ebuild 895 BLAKE2B 31f901a3a2947f46dece5934630d4ddf6ba89697f0894040287ddbc6768489802c1b3b0ba268f8a098cc672a0b9e971f7526799973e87681f86c9b6935602a83 SHA512 58450335de4f49eff79a40dca54df4f20f28906b8f0c606b886bc8f3e01ce0ba5e28453faa7dff75b42b20095b1375c84b0251163549caf523a5dc2d3e93b8c3
+EBUILD dirty-equals-0.5.0.ebuild 798 BLAKE2B bcad36c08db5fa1f5e91f3db57fab4650eb67b123dfa81d833b47ee46b1e73df758b67995721ffd9da2b9ad22e57835ebda5bcaf6bdad93a6cb9ca7e2cd9b124 SHA512 5bed7c3cdd2c704e6b85f6486d9963239afe61ac663980f2ca03163f663b8ac909e3a69c50f97c978e532fe75ecd20d97951c417a3bb57b54a352a63f58fc809
MISC metadata.xml 359 BLAKE2B 120f82faf2460b2528927b708a41b2d105248a57af2f3f11966b102237731f9dab87962069728dd78327757c190790f01646c94c228d0e79bf60fbab82e1ca39 SHA512 fb17ee5e8483cd6c5ce840c2f070601c4506b0d62a8c6a80338e8748e57bfb49ee412faf7b95f21c16e5c5730efb9879d8d66fd4fd1c134ca459af3657994f98
diff --git a/dev-python/dirty-equals/dirty-equals-0.5.0.ebuild b/dev-python/dirty-equals/dirty-equals-0.5.0.ebuild
new file mode 100644
index 000000000000..ce09838079c0
--- /dev/null
+++ b/dev-python/dirty-equals/dirty-equals-0.5.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Doing dirty (but extremely useful) things with equals"
+HOMEPAGE="
+ https://dirty-equals.helpmanual.io/
+ https://github.com/samuelcolvin/dirty-equals/
+ https://pypi.org/project/dirty-equals/
+"
+SRC_URI="
+ https://github.com/samuelcolvin/dirty-equals/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pytz-2021.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x TZ=UTC
+ epytest
+}