summaryrefslogtreecommitdiff
path: root/dev-python/dirty-equals/dirty-equals-0.6.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-30 21:21:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-30 21:21:38 +0100
commit2f210c93c08515a806199783aabe37d12a0197cb (patch)
tree8b846898d136de0503e4ec3c2cf1f90660ee3336 /dev-python/dirty-equals/dirty-equals-0.6.0-r1.ebuild
parent1c19f0d8d940b35f723e28d8a6ebe388cfacd1d8 (diff)
gentoo auto-resync : 30:05:2023 - 21:21:38
Diffstat (limited to 'dev-python/dirty-equals/dirty-equals-0.6.0-r1.ebuild')
-rw-r--r--dev-python/dirty-equals/dirty-equals-0.6.0-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/dirty-equals/dirty-equals-0.6.0-r1.ebuild b/dev-python/dirty-equals/dirty-equals-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..20c41e070da6
--- /dev/null
+++ b/dev-python/dirty-equals/dirty-equals-0.6.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Doing dirty (but extremely useful) things with equals"
+HOMEPAGE="
+ https://dirty-equals.helpmanual.io/
+ https://github.com/samuelcolvin/dirty-equals/
+ https://pypi.org/project/dirty-equals/
+"
+SRC_URI="
+ https://github.com/samuelcolvin/dirty-equals/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2021.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # require unpackaged pytest-examples
+ tests/test_docs.py
+ )
+
+ local -x TZ=UTC
+ epytest
+}