summaryrefslogtreecommitdiff
path: root/dev-python/dirq
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/dirq
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/dirq')
-rw-r--r--dev-python/dirq/Manifest3
-rw-r--r--dev-python/dirq/dirq-1.7.1.ebuild25
-rw-r--r--dev-python/dirq/metadata.xml20
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/dirq/Manifest b/dev-python/dirq/Manifest
new file mode 100644
index 000000000000..d68980aba620
--- /dev/null
+++ b/dev-python/dirq/Manifest
@@ -0,0 +1,3 @@
+DIST dirq-1.7.1.tar.gz 32645 BLAKE2B ac03910299ce25e0af41f88f7b5c5ed4538c3635dd747a2c1bf6770263b6091e5e0f557a2dcacf2e0183f9bef994d4bf836da4383d62b27507eb150d4cd7f371 SHA512 8865f395e6ef81131c5e1df9f97cf1768557af06d446a79ece29e23b83c228cbb158099a7e85360423013cd8e5ead8970c5160865f065d16fcc288c2ce9d176f
+EBUILD dirq-1.7.1.ebuild 571 BLAKE2B 31c00c48de4d06a54402a48e844c5b118dc89336850c0af80c3bf0b361c0ecd72de56dd4946848e4366f0a7c48c9e19b5098f76908389682953e30fb1072d06e SHA512 46697b3d47bdc52e0eab739698ad9ab0de4eec6b4822744cb58e7c59264799e5a7c236d0ed1c05b32d869f6b94f1ec67ae77f94655f3d27dfe8267f957fa3c2e
+MISC metadata.xml 737 BLAKE2B fd53eeae3b338d2952c769f861b9902a4deff181ecdd62bffb692c64153011e98a6488b9e26e2005ae1b4be4d394975ec7071a78bb3e32155165311df6298dac SHA512 b5444242e60c9e2c847c91cdccaf43567bc9e77c6d6a89bc705af98c3eb2cc115f64abeeff191c9803ca50d73af89b6e91c0104d130c45087f11bd3f128a6459
diff --git a/dev-python/dirq/dirq-1.7.1.ebuild b/dev-python/dirq/dirq-1.7.1.ebuild
new file mode 100644
index 000000000000..6bfe5e8640c4
--- /dev/null
+++ b/dev-python/dirq/dirq-1.7.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python port of Perl module Directory::Queue"
+HOMEPAGE="https://github.com/cern-mig/python-dirq"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Note: as of 2017-03-22, dirq tests are known to fail in Docker containers
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/dirq/metadata.xml b/dev-python/dirq/metadata.xml
new file mode 100644
index 000000000000..2e025c6c0714
--- /dev/null
+++ b/dev-python/dirq/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <longdescription lang="en">
+ The goal of this module is to offer a queue system using the underlying
+ filesystem for storage, security and to prevent race conditions via
+ atomic operations. It focuses on simplicity, robustness and scalability.
+
+ This module allows multiple concurrent readers and writers to interact
+ with the same queue.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">cern-mig/python-dirq</remote-id>
+ <remote-id type="pypi">dirq</remote-id>
+ </upstream>
+</pkgmetadata>