summaryrefslogtreecommitdiff
path: root/dev-python/diff-cover
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
commit121ed4eec41fbf03e1998d09eede1bf449da63b9 (patch)
treece9341d77d1507f67d4a3a1472da9011b5baa0a8 /dev-python/diff-cover
parentdd762ff83c330186ee2ede002e08b2f780cddd51 (diff)
gentoo resync : 19.07.2019
Diffstat (limited to 'dev-python/diff-cover')
-rw-r--r--dev-python/diff-cover/Manifest2
-rw-r--r--dev-python/diff-cover/diff-cover-2.3.0.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/diff-cover/Manifest b/dev-python/diff-cover/Manifest
index b375302a2bac..da955534e819 100644
--- a/dev-python/diff-cover/Manifest
+++ b/dev-python/diff-cover/Manifest
@@ -1,3 +1,5 @@
DIST diff-cover-1.0.4.tar.gz 73907 BLAKE2B 81562c30533739f950e52703ce235b214f66932f806a47b1ab245b69bba8ef46d4333924ddf2ba4ca6b70a7df85ae071805a4fac7181711495f46540c4a20301 SHA512 aa5646c5d097e2b3ace5807bde007c9d8ebcf99578dee2aff1174aaafbdb9777c4794a8e9ddd4dc6edb5af7f1afc812fce4410db87d0bab4159f044489eabb5b
+DIST diff-cover-2.3.0.tar.gz 76738 BLAKE2B 467d8ed3cb2f4b0f76ad6b1928a87ad6f75ce46e555c061e30b56fc4856089fb270670ad9f704b9dc407e5c6cab2cf881696bd263befafbe3863bcda4ccd4ac2 SHA512 c47d64e1695596ba1244d687cdbbd6edf391b0c4a18b2550004bcfc36ce8798ef9e6a059e726e52eff45251b3bb27cca873be493c37b3b7eab9dec02f99953f6
EBUILD diff-cover-1.0.4.ebuild 1039 BLAKE2B 3177e8f9381bd12d818befbbfe22d074dd1a99bdfd17c29dd09e56797f0f83a39107da1d21428325a32bf8929d1b2655db7838d3b27dc214cc79a16f3dc1a9b0 SHA512 6091446254f177768f0d04ebac7f5d754435965b0bcae732f946bd7f624275766066b08e78b440bd76410c508d070aa5cf074e4449f0a79c6b936a42b5e7d174
+EBUILD diff-cover-2.3.0.ebuild 1323 BLAKE2B 34db5fe4ccc7fd623d02e1428eb2de0560bd546391f27d84cb0a400d260fab82306901e11b43bd06a04bd6f1614cf2f6b87a42946a61cca850282884a78278c3 SHA512 d2ddf235db1dc0d11b7e1f79ee2fed4a55e098ce8f937fe9a55bf0911adce4627b84a08c5cff8062f783f9fbb83769035f6c975359c4abd5b792ef28fc9f6ac8
MISC metadata.xml 380 BLAKE2B b3fee2fecc0de95a5056955412d4f069a57a405a887966c1511c4c63f6c2c77778ace33d439fd37c6b5db62c247fa7fcd71c15f6cc8a97de46e72a841aaa9514 SHA512 80581412380ac1b87077d5e1c74596434ae398bc9b654c5492db7ce60270e9ad40c0e13b5c95a11cae57bef6b2a1dfa8888f8061a2ff221acdfc30c21e57242e
diff --git a/dev-python/diff-cover/diff-cover-2.3.0.ebuild b/dev-python/diff-cover/diff-cover-2.3.0.ebuild
new file mode 100644
index 000000000000..b16f1d1cad99
--- /dev/null
+++ b/dev-python/diff-cover/diff-cover-2.3.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically find diff lines that need test coverage"
+HOMEPAGE="https://github.com/Bachmann1234/diff-cover"
+SRC_URI="https://github.com/Bachmann1234/diff-cover/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7.1[${PYTHON_USEDEP}]
+ dev-python/jinja2_pluralize[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.4.0[${PYTHON_USEDEP}]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ )"
+
+MY_PN=${PN/-/_}
+S=${WORKDIR}/${MY_PN}-${PV}
+
+python_prepare_all() {
+ # TypeError: test_parse_range_notation() takes exactly 2 arguments (1 given)
+ sed -e 's|test_parse_range_notation|_\0|' \
+ -i "${MY_PN}/tests/test_diff_cover_main.py" || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test || die "tests failed with ${EPYTHON}"
+}