summaryrefslogtreecommitdiff
path: root/dev-python/dib-utils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/dib-utils
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/dib-utils')
-rw-r--r--dev-python/dib-utils/Manifest6
-rw-r--r--dev-python/dib-utils/dib-utils-0.0.10.ebuild21
-rw-r--r--dev-python/dib-utils/dib-utils-0.0.8.ebuild21
-rw-r--r--dev-python/dib-utils/metadata.xml21
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/dib-utils/Manifest b/dev-python/dib-utils/Manifest
new file mode 100644
index 000000000000..3548c0db47f2
--- /dev/null
+++ b/dev-python/dib-utils/Manifest
@@ -0,0 +1,6 @@
+DIST dib-utils-0.0.10.tar.gz 9146 SHA256 680c4aa256d7a65dff4308716a1c23e6f0e09b1f74a34033ed3d0c0316290261 SHA512 7a73748ebea78f93136518fe599fcb10a27d8c9c432398fee7fd87a93207bc18154547f9af4f85c7c04d684d13c777f1a2da0287b0f3195303866fd541a18d68 WHIRLPOOL 6bb852c7f920998f0f6573fbd41063a54e2d5bbbadcf2378efe245b018a3ffd4925818eb6ded7925b114bc562053b35e604ccf6c013dbb29f15df97afde549df
+DIST dib-utils-0.0.8.tar.gz 7764 SHA256 f28042c47518b1e73ac430f8261057eb61126c43e7c3bebbeafdf8edf045c68a SHA512 a639a142156027ebe6ca9d5fba6458175b2db37dae14f8cde75d9c32c1903e5774a9cf69d1c251af17ce1c98a4ff28238a8abe75c32956b9605b23ff327f980c WHIRLPOOL 7bd819a5599aa0a31a8baabfb59947ff35e6fbdaf1331c9be408cfe1b464eef91a87fd516f7d2ff7a1398965c3287b8a5f2a196b6c9e087276855ed97a082f04
+EBUILD dib-utils-0.0.10.ebuild 564 SHA256 9ed830228fb56a747d5c24faf27aa3086605d6f46baa1f5d74a19af7ba7e1152 SHA512 f5481f80ffb47f019f654dac8f72abbe81fa325e8fe8c57c60f3ba4fbc91b23bdb2b948840a3c5c6a6772b78cd532535c9f62833d8817a974580295738c5e490 WHIRLPOOL 0ab87d8dcdf4110c125ebd558529e9c06a34a895479228ba04fb755c6aa545f966ebdc56ae4ace32ecd3c1d92841015b666278e354750646a625daca174e7daa
+EBUILD dib-utils-0.0.8.ebuild 566 SHA256 f5e0c610ef41a5db3d411ae8a368f980f81d3123122be2779385c16e13c1cbc5 SHA512 29f9ed47df2756949aaf2098cb287c36496dd373a136e74faaddf3b7b62a65999517037f651ea6bdf4b4e25405456c673536dc021250467647952df5089bb1cf WHIRLPOOL cf88667167d1956a5bc9be06af30556c6a0c968dc5b7be720adb53ac9b81c3fa634f4f771751a0d0920ddd05414d0bcd833b8f409347f029f3aae1dd20c91e95
+MISC ChangeLog 503 SHA256 35a3055db17bacd40b5b1656ef7da48dae26211d89ff0a21a4dc0020935cc278 SHA512 49c372ce9258f7ea42b89325b35c136e74f81bddb47018822521483c2ae4b3947de746a3d9147ec12323517edf990b5f6411aba841de8061f2061b32592ca533 WHIRLPOOL 690c53642ccb6ac342ac405cf3cfc197af3558ef1ca971b47a562f69777bdb6f701335e19e8d583fdf1151df34aec1b1ac69b2d038b793f497caddd77cc44bd9
+MISC metadata.xml 666 SHA256 8beae78f04147a8e381b2a29bbd76e86dceaddb886e9c838469c93ba17a2015a SHA512 3905d6028d0b680ddbb63b50491bf57a693b8b4a2473cc3204d87234a23fbe9a4c6c34a6a4811201ecfc2114b99406f7a745f57793ac4bd830aff6b6c30234e1 WHIRLPOOL bc5daa566d3f3a6e8bbe34dcd80d87fba7ce23e5e135d832547ac97c3ce6d6bf64cad215c708d6d9e31e3524f298f45429b53c481d0004746d090c55af3afcaf
diff --git a/dev-python/dib-utils/dib-utils-0.0.10.ebuild b/dev-python/dib-utils/dib-utils-0.0.10.ebuild
new file mode 100644
index 000000000000..3d036390f017
--- /dev/null
+++ b/dev-python/dib-utils/dib-utils-0.0.10.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Standalone tools related to diskimage-builder."
+HOMEPAGE="https://git.openstack.org/cgit/openstack/dib-utils"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}"
diff --git a/dev-python/dib-utils/dib-utils-0.0.8.ebuild b/dev-python/dib-utils/dib-utils-0.0.8.ebuild
new file mode 100644
index 000000000000..3fb0870f6427
--- /dev/null
+++ b/dev-python/dib-utils/dib-utils-0.0.8.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Standalone tools related to diskimage-builder."
+HOMEPAGE="https://git.openstack.org/cgit/openstack/dib-utils"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}"
diff --git a/dev-python/dib-utils/metadata.xml b/dev-python/dib-utils/metadata.xml
new file mode 100644
index 000000000000..f1ec9a48bdd3
--- /dev/null
+++ b/dev-python/dib-utils/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>openstack@gentoo.org</email>
+ <name>Openstack</name>
+ </maintainer>
+ <longdescription lang="en">
+ These tools were originally part of the
+ diskimage-builder project, but they have
+ uses outside of that project as well.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">dib-utils</remote-id>
+ <remote-id type="github">openstack/dib-utils</remote-id>
+ </upstream>
+</pkgmetadata>