summaryrefslogtreecommitdiff
path: root/dev-python/demjson/demjson-2.2.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/demjson/demjson-2.2.4.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/demjson/demjson-2.2.4.ebuild')
-rw-r--r--dev-python/demjson/demjson-2.2.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/demjson/demjson-2.2.4.ebuild b/dev-python/demjson/demjson-2.2.4.ebuild
new file mode 100644
index 000000000000..a31928f9ea2b
--- /dev/null
+++ b/dev-python/demjson/demjson-2.2.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Encoder, decoder, and lint/validator for JSON compliant with RFC 4627"
+HOMEPAGE="http://deron.meranda.us/python/demjson/ https://pypi.org/project/demjson/"
+SRC_URI="http://deron.meranda.us/python/${PN}/dist/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_test() {
+ cd test
+ if python_is_python3; then
+ 2to3 -w --no-diffs test_demjson.py
+ fi
+ "${PYTHON}" test_demjson.py
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # Docs are .txt files
+ if use doc; then
+ dodoc docs/*.txt || die "Installation of documentation failed"
+ fi
+}