summaryrefslogtreecommitdiff
path: root/dev-python/decoratortools/decoratortools-1.8-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /dev-python/decoratortools/decoratortools-1.8-r1.ebuild
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'dev-python/decoratortools/decoratortools-1.8-r1.ebuild')
-rw-r--r--dev-python/decoratortools/decoratortools-1.8-r1.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/decoratortools/decoratortools-1.8-r1.ebuild b/dev-python/decoratortools/decoratortools-1.8-r1.ebuild
deleted file mode 100644
index 91487d35a326..000000000000
--- a/dev-python/decoratortools/decoratortools-1.8-r1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-MY_PN="DecoratorTools"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Class, function, and metaclass decorators"
-HOMEPAGE="https://pypi.org/project/DecoratorTools/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
-
-LICENSE="|| ( PSF-2 ZPL )"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ppc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE=""
-
-DEPEND="
- app-arch/unzip
- dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- # Disable tests broken with named tuples.
- sed -e "s/additional_tests/_&/" -i test_decorators.py || die "sed failed"
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- esetup.py test
-}