summaryrefslogtreecommitdiff
path: root/dev-python/debugpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-21 03:55:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-21 03:55:39 +0100
commit206ec2c4ffbadc599d05d0abde0ca644856bbf68 (patch)
treef04e1bc391d39db1b3de66e2ac313f245f133ef2 /dev-python/debugpy
parent62058fa8f1b95418543f8ae008b247d44cc8b09c (diff)
gentoo auto-resync : 21:10:2023 - 03:55:38
Diffstat (limited to 'dev-python/debugpy')
-rw-r--r--dev-python/debugpy/Manifest3
-rw-r--r--dev-python/debugpy/debugpy-1.8.0.ebuild66
-rw-r--r--dev-python/debugpy/files/debugpy-1.8.0-unbundle-pydevd.patch46
3 files changed, 115 insertions, 0 deletions
diff --git a/dev-python/debugpy/Manifest b/dev-python/debugpy/Manifest
index 2e6c6e66f59e..547b0f21d619 100644
--- a/dev-python/debugpy/Manifest
+++ b/dev-python/debugpy/Manifest
@@ -1,4 +1,7 @@
AUX debugpy-1.6.6-unbundle-pydevd.patch 2531 BLAKE2B c7cf5cc10a75393b191ab3ecd3137b2d4df30a0611b76fd18bf1822aa61c06ec912358afe6da420c1ace3314e12b57079cadb0deebeb19fc3242f75f7ef5860a SHA512 98d6557c516617273a1a75c5269733f02d55754078ba9a5137f9abdcddc58275a7ea451f290ecf809003abc614b0865d235a8b712caec71e3811911a4f231448
+AUX debugpy-1.8.0-unbundle-pydevd.patch 1480 BLAKE2B 6694cbb68e8e5793f22fedc9351875810c86c1add4299bbb5360dedc24bcbdbb0128163cc11dab3effc611dbe5ef43ea45e9504914f6c55f4f66b76b9da0b804 SHA512 553ce357019e561e50770bf747adc33ac037cf5aa9fc08c44ce9c1cb87ecba28b7c632adb5b743c38067c1bb6b97f1d239ad8dee404332bc8028be44afd018ce
DIST debugpy-1.6.6.gh.tar.gz 6942488 BLAKE2B 18c6eee2322239e5cbbacf9431fa7480abcf14a68f290d2228edc8b2ead042e7b09d19ee5bcc60be32e8a6b0b34b925eaa8246991298744f3ca74d4ed2ea3f3e SHA512 1a209bfd702d5f0649ce50b0910023e295953dd39cefdefb0b5af1d6023e629a727610789cd244e656bdf4276cee957fa463506ddaca603ab3ee85cc250dc212
+DIST debugpy-1.8.0.gh.tar.gz 6760323 BLAKE2B 99c4188c0b0383dc4dcbdd86c4d35e6eb973ca32ba56b757adea9668b161f20f17b436e0dc019790b1e85586387fc848712143c5e3d3814e2522850d97a4048e SHA512 f9e47371ca854c12811d1c0984f063b1ad5cac2bea769f91a67f9fa125cfcbeccbecafca9b9d5ea16a4ed8a1c123f34db3ba19efe1567b93a86cbd325239b355
EBUILD debugpy-1.6.6.ebuild 1145 BLAKE2B c9fab7600289a7c493412da331daf21d570536187d44ee0f9985a7007393413643e1a28f51e71f22430b58646140cc08aea05eaf227fd47cb22e50ba7affad07 SHA512 a80aea8f84167cfbc8a54dcb183f7ce71cba4e6ab288351223c83820aaa68a0f60d56f97cbe5499163712130ea3689d6bb8b0de3b009f829a5fc61be3c0e979c
+EBUILD debugpy-1.8.0.ebuild 1634 BLAKE2B 2b38e01e72a960547a281c348e64af40782ce55813254ab70dbf4aed418337c96b6ebaf2bbfba2456232fd3615bf6df9888d14e3034907dfb60a115f0058a069 SHA512 604709b07be073806affaf281024740959fad5939c08ab87690e8be6359b100ce1d9ae8267df8d3f4145b4ccd6f2fc76522e87b6a5ddf08ae136c817470936d4
MISC metadata.xml 508 BLAKE2B f5af1472be02222c1eb89246c4c4b782aaf5de8dd785aa983bbee6df69982b96c276310480a7ffbf2ac0105268507474d3b0823fc9e0bff89acfe648a2cc490f SHA512 d4697748bc79f4c684dd3bf58e52b211e8ba7816041840e705b896f2731a1a0518a01d7b7cca5e441bbc88e6eb272175c26681517873883068c4fe1bc864c09b
diff --git a/dev-python/debugpy/debugpy-1.8.0.ebuild b/dev-python/debugpy/debugpy-1.8.0.ebuild
new file mode 100644
index 000000000000..bf665f0da2e0
--- /dev/null
+++ b/dev-python/debugpy/debugpy-1.8.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="An implementation of the Debug Adapter Protocol for Python"
+HOMEPAGE="
+ https://github.com/microsoft/debugpy/
+ https://pypi.org/project/debugpy/
+"
+SRC_URI="
+ https://github.com/microsoft/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pydevd[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Unbundle dev-python/pydevd
+ rm -r src/debugpy/_vendored/pydevd || die
+ local PATCHES=(
+ "${FILESDIR}/${PN}-1.8.0-unbundle-pydevd.patch"
+ )
+
+ # Drop unnecessary and unrecognized option
+ # __main__.py: error: unrecognized arguments: -n8
+ # Do not timeout
+ sed -e '/addopts/d' -e '/timeout/d' -i pytest.ini || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local EPYTEST_DESELECT=(
+ tests/debugpy/test_gevent.py::test_gevent
+ tests/debugpy/test_run.py::test_custom_python_args
+ tests/tests/test_timeline.py::test_occurrences
+ )
+ local EPYTEST_IGNORE=(
+ tests/tests/test_vendoring.py
+ )
+ epytest -p timeout -p xdist -n "$(makeopts_jobs)" --dist=worksteal \
+ -k "not attach_pid"
+}
diff --git a/dev-python/debugpy/files/debugpy-1.8.0-unbundle-pydevd.patch b/dev-python/debugpy/files/debugpy-1.8.0-unbundle-pydevd.patch
new file mode 100644
index 000000000000..54ccdae4ca01
--- /dev/null
+++ b/dev-python/debugpy/files/debugpy-1.8.0-unbundle-pydevd.patch
@@ -0,0 +1,46 @@
+diff --git a/setup.py b/setup.py
+index 0bb4f00..abfce1c 100644
+--- a/setup.py
++++ b/setup.py
+@@ -18,12 +18,10 @@ del sys.path[0]
+
+ sys.path.insert(0, os.path.join(os.path.dirname(os.path.abspath(__file__)), "src"))
+ import debugpy
+-import debugpy._vendored
+
+ del sys.path[0]
+
+
+-PYDEVD_ROOT = debugpy._vendored.project_root("pydevd")
+ DEBUGBY_ROOT = os.path.dirname(os.path.abspath(debugpy.__file__))
+
+
+@@ -146,8 +144,6 @@ if __name__ == "__main__":
+ extras["platforms"] = platforms
+
+ cmds = versioneer.get_cmdclass()
+- override_build(cmds)
+- override_build_py(cmds)
+
+ setuptools.setup(
+ name="debugpy",
+diff --git a/src/debugpy/_vendored/force_pydevd.py b/src/debugpy/_vendored/force_pydevd.py
+index cfd8927..0cb1bca 100644
+--- a/src/debugpy/_vendored/force_pydevd.py
++++ b/src/debugpy/_vendored/force_pydevd.py
+@@ -8,15 +8,6 @@ import warnings
+
+ from . import check_modules, prefix_matcher, preimport, vendored
+
+-# Ensure that pydevd is our vendored copy.
+-_unvendored, _ = check_modules('pydevd',
+- prefix_matcher('pydev', '_pydev'))
+-if _unvendored:
+- _unvendored = sorted(_unvendored.values())
+- msg = 'incompatible copy of pydevd already imported'
+- # raise ImportError(msg)
+- warnings.warn(msg + ':\n {}'.format('\n '.join(_unvendored)))
+-
+ # If debugpy logging is enabled, enable it for pydevd as well
+ if "DEBUGPY_LOG_DIR" in os.environ:
+ os.environ[str("PYDEVD_DEBUG")] = str("True")