summaryrefslogtreecommitdiff
path: root/dev-python/debugpy/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-02 21:08:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-02 21:08:25 +0000
commitc107831b9ebfe892c139cdb68d747eea369d8588 (patch)
tree3e2fbc0ea06bf0ea7a5fdf0250036433cd4bc11f /dev-python/debugpy/files
parent52895d302231ef73b105756d2781b2262638d566 (diff)
gentoo auto-resync : 02:02:2023 - 21:08:25
Diffstat (limited to 'dev-python/debugpy/files')
-rw-r--r--dev-python/debugpy/files/debugpy-1.6.6-unbundle-pydevd.patch77
1 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/debugpy/files/debugpy-1.6.6-unbundle-pydevd.patch b/dev-python/debugpy/files/debugpy-1.6.6-unbundle-pydevd.patch
new file mode 100644
index 000000000000..d285775c9246
--- /dev/null
+++ b/dev-python/debugpy/files/debugpy-1.6.6-unbundle-pydevd.patch
@@ -0,0 +1,77 @@
+diff --git a/pyproject.toml b/pyproject.toml
+index 9a79e55..8725d19 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -8,7 +8,6 @@ exclude = '''
+ ( __pycache__
+ | ^/.tox
+ | ^/versioneer.py
+-| ^/src/debugpy/_vendored
+ | ^/src/debugpy/_version.py
+ )
+ '''
+diff --git a/setup.py b/setup.py
+index 3abc811..c11924c 100644
+--- a/setup.py
++++ b/setup.py
+@@ -18,12 +18,10 @@ del sys.path[0]
+
+ sys.path.insert(0, os.path.join(os.path.dirname(os.path.abspath(__file__)), "src"))
+ import debugpy
+-import debugpy._vendored
+
+ del sys.path[0]
+
+
+-PYDEVD_ROOT = debugpy._vendored.project_root("pydevd")
+ DEBUGBY_ROOT = os.path.dirname(os.path.abspath(debugpy.__file__))
+
+
+@@ -146,8 +144,6 @@ if __name__ == "__main__":
+ extras["platforms"] = platforms
+
+ cmds = versioneer.get_cmdclass()
+- override_build(cmds)
+- override_build_py(cmds)
+
+ setuptools.setup(
+ name="debugpy",
+@@ -183,14 +179,9 @@ if __name__ == "__main__":
+ "debugpy.common",
+ "debugpy.launcher",
+ "debugpy.server",
+- "debugpy._vendored",
+ ],
+ package_data={
+ "debugpy": ["ThirdPartyNotices.txt"],
+- "debugpy._vendored": [
+- # pydevd extensions must be built before this list can be computed properly,
+- # so it is populated in the overridden build_py.finalize_options().
+- ],
+ },
+ ext_modules=ExtModules(),
+ has_ext_modules=lambda: True,
+diff --git a/src/debugpy/server/__init__.py b/src/debugpy/server/__init__.py
+index 42d5367..e333dcf 100644
+--- a/src/debugpy/server/__init__.py
++++ b/src/debugpy/server/__init__.py
+@@ -1,7 +1,3 @@
+ # Copyright (c) Microsoft Corporation. All rights reserved.
+ # Licensed under the MIT License. See LICENSE in the project root
+ # for license information.
+-
+-# "force_pydevd" must be imported first to ensure (via side effects)
+-# that the debugpy-vendored copy of pydevd gets used.
+-import debugpy._vendored.force_pydevd # noqa
+diff --git a/src/debugpy/server/attach_pid_injected.py b/src/debugpy/server/attach_pid_injected.py
+index a8df6e1..a29a969 100644
+--- a/src/debugpy/server/attach_pid_injected.py
++++ b/src/debugpy/server/attach_pid_injected.py
+@@ -31,7 +31,6 @@ def attach(setup):
+ pydevd_attach_to_process_path = os.path.join(
+ _debugpy_dir,
+ "debugpy",
+- "_vendored",
+ "pydevd",
+ "pydevd_attach_to_process",
+ )