summaryrefslogtreecommitdiff
path: root/dev-python/debugpy/debugpy-1.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-24 20:44:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-24 20:44:11 +0100
commit342922f04a58a969ff23806acc427c7ff79119ce (patch)
tree7c491f1183b65ff952aefc31909ea49a54196be0 /dev-python/debugpy/debugpy-1.8.0.ebuild
parent27f59f8e16510831cc751de1406f71afbf464653 (diff)
gentoo auto-resync : 24:10:2023 - 20:44:11
Diffstat (limited to 'dev-python/debugpy/debugpy-1.8.0.ebuild')
-rw-r--r--dev-python/debugpy/debugpy-1.8.0.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-python/debugpy/debugpy-1.8.0.ebuild b/dev-python/debugpy/debugpy-1.8.0.ebuild
index bf665f0da2e0..5324eccaca25 100644
--- a/dev-python/debugpy/debugpy-1.8.0.ebuild
+++ b/dev-python/debugpy/debugpy-1.8.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 multiprocessing
@@ -61,6 +61,15 @@ python_test() {
local EPYTEST_IGNORE=(
tests/tests/test_vendoring.py
)
+
+ case ${EPYTHON} in
+ python3.12)
+ EPYTEST_DESELECT+=(
+ tests/debugpy/test_flask.py
+ )
+ ;;
+ esac
+
epytest -p timeout -p xdist -n "$(makeopts_jobs)" --dist=worksteal \
-k "not attach_pid"
}