summaryrefslogtreecommitdiff
path: root/dev-python/debugpy/debugpy-1.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-20 11:23:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-20 11:23:36 +0100
commitc17e7d2a8cc12551a02d28209cd2edbf078d5675 (patch)
treecde162c484c03f53827a78ec75a7f153d18933d3 /dev-python/debugpy/debugpy-1.6.2.ebuild
parent295483480d7b8ba2fff987fdd32eaa36fe730ce4 (diff)
gentoo auto-resync : 20:09:2022 - 11:23:36
Diffstat (limited to 'dev-python/debugpy/debugpy-1.6.2.ebuild')
-rw-r--r--dev-python/debugpy/debugpy-1.6.2.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/debugpy/debugpy-1.6.2.ebuild b/dev-python/debugpy/debugpy-1.6.2.ebuild
deleted file mode 100644
index 4c731f772480..000000000000
--- a/dev-python/debugpy/debugpy-1.6.2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
-
-DESCRIPTION="An implementation of the Debug Adapter Protocol for Python"
-HOMEPAGE="https://github.com/microsoft/debugpy/ https://pypi.org/project/debugpy/"
-SRC_URI="
- https://github.com/microsoft/${PN}/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
-
-# This is completely broken
-RESTRICT="test"
-
-RDEPEND="dev-python/pydevd[${PYTHON_USEDEP}]"
-BDEPEND="test? ( dev-python/pytest-timeout[${PYTHON_USEDEP}] )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.6.1-unbundle-pydevd.patch"
-)
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Drop unnecessary and unrecognized option
- # __main__.py: error: unrecognized arguments: -n8
- # Do not timeout
- sed -e '/addopts/d' -e '/timeout/d' -i pytest.ini || die
-
- # Unbundle dev-python/pydevd
- rm -r src/debugpy/_vendored tests/tests/test_vendoring.py || die
-
- distutils-r1_python_prepare_all
-}