summaryrefslogtreecommitdiff
path: root/dev-python/debugpy/debugpy-1.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-python/debugpy/debugpy-1.6.2.ebuild
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-python/debugpy/debugpy-1.6.2.ebuild')
-rw-r--r--dev-python/debugpy/debugpy-1.6.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/debugpy/debugpy-1.6.2.ebuild b/dev-python/debugpy/debugpy-1.6.2.ebuild
new file mode 100644
index 000000000000..87982f97e4bb
--- /dev/null
+++ b/dev-python/debugpy/debugpy-1.6.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="An implementation of the Debug Adapter Protocol for Python"
+HOMEPAGE="https://github.com/microsoft/debugpy/ https://pypi.org/project/debugpy/"
+SRC_URI="
+ https://github.com/microsoft/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# This is completely broken
+RESTRICT="test"
+
+RDEPEND="dev-python/pydevd[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/pytest-timeout[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.6.1-unbundle-pydevd.patch"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Drop unnecessary and unrecognized option
+ # __main__.py: error: unrecognized arguments: -n8
+ # Do not timeout
+ sed -e '/addopts/d' -e '/timeout/d' -i pytest.ini || die
+
+ # Unbundle dev-python/pydevd
+ rm -r src/debugpy/_vendored tests/tests/test_vendoring.py || die
+
+ distutils-r1_python_prepare_all
+}