summaryrefslogtreecommitdiff
path: root/dev-python/dbutils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/dbutils
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/dbutils')
-rw-r--r--dev-python/dbutils/Manifest3
-rw-r--r--dev-python/dbutils/dbutils-1.1-r1.ebuild44
-rw-r--r--dev-python/dbutils/metadata.xml18
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/dbutils/Manifest b/dev-python/dbutils/Manifest
new file mode 100644
index 000000000000..6fca74656495
--- /dev/null
+++ b/dev-python/dbutils/Manifest
@@ -0,0 +1,3 @@
+DIST DBUtils-1.1.tar.gz 109943 BLAKE2B 46b325eff6719f22dd2713d74deb16f5a1caf075d4c53d001208b763e5f5edbe10f3ba9a5e9877a8f1f50915c5d9a14f3911c5ba477258f3c9714897c39d8e09 SHA512 34e2dd85e94bbf13804deb7a40707ed2d83174758af7282702e1614d34924a6ae085bca620da0233bfd8972a00332c022fe764e6e5efa642c3365879cdedf88e
+EBUILD dbutils-1.1-r1.ebuild 963 BLAKE2B fd252bda4c05a069309f53f0afd8caf06813e4cf1ec4eb02a15284f47776d4bfd7d69731d97e2f0ff1ca6d92790532796176f0d372b63d37443b6b1a6333e722 SHA512 88a4476df11c4e398ff0e6d174645c1c751ef348fc1ee7b78be5b2d298f707b7bcb8e017ea8620372f4258c3434488ecfc0aac1b41a950305672480cd51d305b
+MISC metadata.xml 692 BLAKE2B 0d9f3b68a08a952f56283fe308423f0da561bc36c0460fcb5b2a3530eb70544bf5d353f77ac050dfeec680e0440d6d32ec5834a969907f5f38e08559fbb146e0 SHA512 d441db855c228932b5eb74e85a9406e730605f7bd23ee7e0505adccb18839e21caa3c50fc88ff9bf07eb400cfc0a0005704548e4bb46ac155572a8e16a6a378f
diff --git a/dev-python/dbutils/dbutils-1.1-r1.ebuild b/dev-python/dbutils/dbutils-1.1-r1.ebuild
new file mode 100644
index 000000000000..c38aa2a4269a
--- /dev/null
+++ b/dev-python/dbutils/dbutils-1.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="DBUtils"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Database connections for multi-threaded environments"
+HOMEPAGE="https://cito.github.io/DBUtils/
+ https://github.com/Cito/DBUtils
+ https://pypi.org/project/DBUtils/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="OSL-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ sed -i -e "s/, 'DBUtils.Tests'//" \
+ -e "s/, 'DBUtils.Examples'//" \
+ -e "/package_data=/d" \
+ setup.py || die "sed failed"
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -s ${MY_PN}/Tests
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${S}/${MY_PN}"/Docs/. )
+ use examples && local EXAMPLES=( "${MY_PN}"/Examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/dbutils/metadata.xml b/dev-python/dbutils/metadata.xml
new file mode 100644
index 000000000000..caa310978e96
--- /dev/null
+++ b/dev-python/dbutils/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>robbat2@gentoo.org</email>
+<name>Robin H. Johnson</name>
+</maintainer>
+<maintainer type="project">
+<email>python@gentoo.org</email>
+<name>Python</name>
+</maintainer>
+<longdescription lang="en">
+DBUtils is a suite of tools providing solid, persistent and pooled connections
+to a database that can be used in all kinds of multi-threaded environments
+like Webware for Python or other web application servers. The suite supports
+DB-API 2 compliant database interfaces and the classic PyGreSQL interface.
+</longdescription>
+</pkgmetadata>