summaryrefslogtreecommitdiff
path: root/dev-python/dbutils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-17 18:49:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-17 18:49:32 +0000
commit5c94a4b3d11ad7b169e23bd604cf403c96bf4f1c (patch)
tree51700ddb4327326dcc3f915423b58b3842fef379 /dev-python/dbutils
parentd1ad4013179c639433bdbfa5025ca403aac0767b (diff)
gentoo auto-resync : 17:03:2024 - 18:49:32
Diffstat (limited to 'dev-python/dbutils')
-rw-r--r--dev-python/dbutils/Manifest5
-rw-r--r--dev-python/dbutils/dbutils-3.0.3.ebuild31
-rw-r--r--dev-python/dbutils/dbutils-3.1.0.ebuild29
-rw-r--r--dev-python/dbutils/metadata.xml26
4 files changed, 91 insertions, 0 deletions
diff --git a/dev-python/dbutils/Manifest b/dev-python/dbutils/Manifest
new file mode 100644
index 000000000000..fcefb2299dec
--- /dev/null
+++ b/dev-python/dbutils/Manifest
@@ -0,0 +1,5 @@
+DIST DBUtils-3.0.3.tar.gz 94039 BLAKE2B 3b936f42945deb69bd96bd088529f4839452afcd3a9cae66c4d8ff6a16fc3dd2a17e905debdbea3f0122199d8a6e0c664b222a5fa3b358a9fd54b2f8b5bba6ff SHA512 bca7939e2f9f736861b76f60356ea877f346129f66263363fe5dc0201412258653fb45af2a5caad0f0f0b9ebd19f5415113a75168cc28a664418af5475eb0096
+DIST DBUtils-3.1.0.tar.gz 94672 BLAKE2B 296a1fad729d355c2607616e5a3fca2f0131ab6040d2424a15ed4583ee0e22697f5c806d3b3789f7d645bff30dbeca0c49b42a901047e1b8e39fb76143f6bccc SHA512 24ffa16524758c27a617a86afc2d41be0336a498afe88ea6021b9304ecbfa5c98f88221503713e662509ae2a4c36974fad9faea17047ffb2d8b4cd728b44735d
+EBUILD dbutils-3.0.3.ebuild 652 BLAKE2B 844440e7cc99a72721561499da7b828858d3e6ef5245c4fb4c1436fc1cc7a62ce223896eadbea73cae1f68920ce76783fba4fa8e278c2b066412c320f73de23c SHA512 5eaa4168293ff516f4661b19dae4ac0d9e8248b6b8cca551aacb816234275eca36abbb59eed244b2cf7d68b0e0294aa7afe686bed96fe7da6321af1f6a9550d9
+EBUILD dbutils-3.1.0.ebuild 610 BLAKE2B 2b7d05764fa9aed0cb52c8dccaf8854bdc914255be329da939d48143b89c35ad1ad07116658b7697242b1d11d83d43df9d3ec33b3d7f0a633a49dd367266acc2 SHA512 3f6eb97d61f8a14f83aac4e0d9628331d1810b2bb75ae91e50f34bdd88bfe062b8f7a13eca083423edc0d59208541e5b5d83d74bb001b4396787d0ab4f49c10b
+MISC metadata.xml 1005 BLAKE2B e6d13ea0ffdc7d972db2bd8f5f0e2212937e36c1646e900f2eb76cf270ae840db7211d218e6900208bafab3fef0c5226128cebabeb52a51e8204b1981809683c SHA512 ba6884914df60365c4b085b56abcc3e927e780f4f8baa6e2cca745cdc53a1fb18917f1b1532d9e957e515a7d5b8e190d87e556547b98a094062f672b3a1b14cf
diff --git a/dev-python/dbutils/dbutils-3.0.3.ebuild b/dev-python/dbutils/dbutils-3.0.3.ebuild
new file mode 100644
index 000000000000..663d7ef65954
--- /dev/null
+++ b/dev-python/dbutils/dbutils-3.0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=DBUtils
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Database connections for multi-threaded environments"
+HOMEPAGE="
+ https://webwareforpython.github.io/DBUtils/
+ https://github.com/WebwareForPython/DBUtils/
+ https://pypi.org/project/DBUtils/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ dodoc docs/*.rst
+ rm docs/*.rst || die
+ local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/dbutils/dbutils-3.1.0.ebuild b/dev-python/dbutils/dbutils-3.1.0.ebuild
new file mode 100644
index 000000000000..35c376551ebd
--- /dev/null
+++ b/dev-python/dbutils/dbutils-3.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=DBUtils
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Database connections for multi-threaded environments"
+HOMEPAGE="
+ https://webwareforpython.github.io/DBUtils/
+ https://github.com/WebwareForPython/DBUtils/
+ https://pypi.org/project/DBUtils/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/dbutils/metadata.xml b/dev-python/dbutils/metadata.xml
new file mode 100644
index 000000000000..5890a14a76bf
--- /dev/null
+++ b/dev-python/dbutils/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ DBUtils is a suite of tools providing solid, persistent and pooled connections
+ to a database that can be used in all kinds of multi-threaded environments
+ like Webware for Python or other web application servers. The suite supports
+ DB-API 2 compliant database interfaces and the classic PyGreSQL interface.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">WebwareForPython/DBUtils</remote-id>
+ <remote-id type="pypi">DBUtils</remote-id>
+ </upstream>
+</pkgmetadata>