summaryrefslogtreecommitdiff
path: root/dev-python/dbutils/dbutils-1.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/dbutils/dbutils-1.1-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/dbutils/dbutils-1.1-r1.ebuild')
-rw-r--r--dev-python/dbutils/dbutils-1.1-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/dbutils/dbutils-1.1-r1.ebuild b/dev-python/dbutils/dbutils-1.1-r1.ebuild
new file mode 100644
index 000000000000..bfc3136922a9
--- /dev/null
+++ b/dev-python/dbutils/dbutils-1.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="DBUtils"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Database connections for multi-threaded environments"
+HOMEPAGE="http://www.webwareforpython.org/DBUtils https://pypi.python.org/pypi/DBUtils"
+SRC_URI="http://www.webwareforpython.org/downloads/DBUtils/${MY_P}.tar.gz"
+
+LICENSE="OSL-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ sed -i -e "s/, 'DBUtils.Tests'//" \
+ -e "s/, 'DBUtils.Examples'//" \
+ -e "/package_data=/d" \
+ setup.py || die "sed failed"
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -s ${MY_PN}/Tests
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${S}/${MY_PN}"/Docs/. )
+ use examples && local EXAMPLES=( "${MY_PN}"/Examples/. )
+ distutils-r1_python_install_all
+}