summaryrefslogtreecommitdiff
path: root/dev-python/dask
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-02 16:16:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-02 16:16:36 +0100
commite5206efa6e88d32e3819685adee35c49124ccf0e (patch)
treeeb8101c8b97f1aa253537d4ea141dc5bf9c9902b /dev-python/dask
parent15bd3dfb22c7ba23dad0823e326dbcb8bb31b892 (diff)
gentoo auto-resync : 02:09:2023 - 16:16:36
Diffstat (limited to 'dev-python/dask')
-rw-r--r--dev-python/dask/Manifest2
-rw-r--r--dev-python/dask/dask-2023.9.0.ebuild84
2 files changed, 86 insertions, 0 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index 93f8d24ae441..6f98bfbda22f 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -1,5 +1,7 @@
DIST dask-2023.8.0.gh.tar.gz 8539262 BLAKE2B 3ce61191bca458e32ac88904460f8ee843f34ddc9be88d0de7f56a90897dd599d70012f92b5063b5df996bc61c85c16b2d6b745e1a334847d8b66f66721bc422 SHA512 9afee3571e58b0f923347e2ec06c80ab5e4f35abb23e0635777170def0561cf1df6c940844cad1efe112059909020cf6435147b9003c4a449eba98d38d9eefab
DIST dask-2023.8.1.gh.tar.gz 8541743 BLAKE2B 485a88354d3aa54ff1f6afb1bd4a8b3317a6a48b519bef4dadf1bcbb240f21e54eb165f2c076ea8aa9b5753fd8714af26453858d7fe154bb015489f89b8114be SHA512 4ca231236e5d868f8fbb69b38721e495a44fbc982a53ea087ef68085c4df2cc99526b5a66b7fee93a3b63a6cd621f8448b877b98370b3dfe1a32e386dd91e73e
+DIST dask-2023.9.0.gh.tar.gz 8541973 BLAKE2B 06e04377f8f7d0e6a6487c1c2aa52e61a8ab73a04455e9a6d7da238bd747d7ac6cf1526f645f0c874f2588f28708139f8fb1fa0271e6166442be6a15ce68b9f1 SHA512 eadc3a9cd5d8d960d8006db2641e5513a093b4818c1cd4de058d70f088ef1cfd74413abcf0bbba757d9188de4b3c103a3fdfe4ce76f14554b589540011c53835
EBUILD dask-2023.8.0.ebuild 2634 BLAKE2B f34d0f231c2a4b8e56b0f6bfb5c6de73c86b7ee99057d138db13d146b6dd73743a9df05fc27d52e7b4c9d894ed173cfe952075b744bab0d82186ce5aeda60721 SHA512 d88db20fbe8f8dd85879c385dce2ecef5796f6be883eb158be3481ebf82c88d0ca46ce6a1b7894842f75ddcdd6f5028cf88a2c0d8a365680294c2fb30c7717a1
EBUILD dask-2023.8.1.ebuild 2690 BLAKE2B 0fb80034035c15515794ce8e2fc146b179d593ad7acf03d63d464ac757452c0163d4ef65b2c6fbe5197446f3e5a8ff9a9274025887d9d0ff54323803fcd625f3 SHA512 99bfb1009e403d4aa5530c6353216757b391efc23692d20b3c285856a0812ee185b1c57ba13ebe32616fbfc791a9c6916daa9661e556350d04b52b1ee135f708
+EBUILD dask-2023.9.0.ebuild 2690 BLAKE2B 0fb80034035c15515794ce8e2fc146b179d593ad7acf03d63d464ac757452c0163d4ef65b2c6fbe5197446f3e5a8ff9a9274025887d9d0ff54323803fcd625f3 SHA512 99bfb1009e403d4aa5530c6353216757b391efc23692d20b3c285856a0812ee185b1c57ba13ebe32616fbfc791a9c6916daa9661e556350d04b52b1ee135f708
MISC metadata.xml 724 BLAKE2B 9af7553cec2b66228a21f146372d86b8d620048d68f94c1fd09006c8ee7ddaa4e212c2a359b937a5ee37ac23df01e10af0796e8b4cf952237cb4c73a2dff7ca0 SHA512 89b83402c13b06f7adf10cd1cc08b96b90dbc2ca3b5c0c6c422b6e2394e03fd51346306479557c11fcfdbd4a81a574890f2367228ea38531b5f05c02a30b8dcb
diff --git a/dev-python/dask/dask-2023.9.0.ebuild b/dev-python/dask/dask-2023.9.0.ebuild
new file mode 100644
index 000000000000..1f6ccd0af63e
--- /dev/null
+++ b/dev-python/dask/dask-2023.9.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="
+ https://www.dask.org/
+ https://github.com/dask/dask/
+ https://pypi.org/project/dask/
+"
+SRC_URI="
+ https://github.com/dask/dask/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/click-8.0[${PYTHON_USEDEP}]
+ >=dev-python/cloudpickle-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.9.0[${PYTHON_USEDEP}]
+ >=dev-python/importlib-metadata-4.13.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.21[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.3[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ >=dev-python/partd-1.2.0[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ >=dev-python/versioneer-0.28[${PYTHON_USEDEP}]
+ test? (
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # fails with sqlalchemy-2.0, even though we don't use it x_x
+ sed -i -e '/RemovedIn20Warning/d' pyproject.toml || die
+ sed -i -e 's:--cov-config=pyproject.toml::' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # more tests relying on -Werror
+ "dask/array/tests/test_overlap.py::test_map_overlap_no_depth[None]"
+ dask/array/tests/test_random.py::test_RandomState_only_funcs
+ # TODO
+ dask/array/tests/test_reductions.py::test_mean_func_does_not_warn
+ dask/tests/test_config.py::test__get_paths
+ dask/array/tests/test_linalg.py::test_solve_assume_a
+ "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>0-float-5-1-True]"
+ "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>1-float-5-1-True]"
+ dask/array/tests/test_image.py::test_preprocess
+ dask/tests/test_system.py::test_cpu_count_cgroups_v2
+ # require sqlalchemy<2.0
+ dask/dataframe/io/tests/test_sql.py
+ )
+
+ if ! has_version -b "dev-python/pyarrow[parquet,${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ # fails if pyarrow is installed without USE=parquet
+ # (optional dep, skipped if it's not installed at all)
+ dask/dataframe/io/tests/test_parquet.py::test_pyarrow_filter_divisions
+ )
+ fi
+
+ epytest -p no:flaky -m "not network"
+}