summaryrefslogtreecommitdiff
path: root/dev-python/dask
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-15 13:50:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-15 13:50:34 +0100
commit7b0230b9f0a5cbd2779e7b25d57df8c33b6d0a88 (patch)
treea6a3e9599958059e99a9753cffba162ceb14b9b9 /dev-python/dask
parentafc11599d81c08d253ed16222206ccd408d6c3cf (diff)
gentoo auto-resync : 15:10:2022 - 13:50:34
Diffstat (limited to 'dev-python/dask')
-rw-r--r--dev-python/dask/Manifest2
-rw-r--r--dev-python/dask/dask-2022.10.0.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index 2fca2075923d..3df4e298f859 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -1,6 +1,8 @@
+DIST dask-2022.10.0.gh.tar.gz 8778168 BLAKE2B d352f574cbf478747a95896c8b074c40c9bb413ccc6cd7b12d344b0dc7dc89bdc0613bf5b142e000b85f1c2a5a02e6eb8ac00b6db459a8580927cb4d7c54cf46 SHA512 d35ee0c710f4cccbdddca028a33f3f855ea26f94bebae1dd2a8c761cd0d116324daa03fd7fb5a4cb57d040f549f922b7373a0c089c9667b4da25fbb3b83efa02
DIST dask-2022.9.0.gh.tar.gz 8762083 BLAKE2B 60c7a37124b61b49fc06a754b5842695fd63d234e087ec44a40793aeb330034e0d5e3caaedd239fd498a9b01c2bc450f62cdc22848bfd654bfdab6a07d9be7de SHA512 a88f71b9e8cdc69ce3a4babbc2434f830110df284d56eec37cadb6b81add3cd5f2e751ea5e9b390d112d16ee0952c296368851889fec202e3601c2fcf8f52a97
DIST dask-2022.9.1.gh.tar.gz 8766675 BLAKE2B da4735dd860b96d691bbe3782ce04fb4e53a265984dc52593ecd1cbd1a1e536ad2677998e01bcfa99d783255ce053a44c4ed4cb0ce83128520755c20530bca3f SHA512 944d333bbe2f946b85173d289e287737816359a959b61d9bf2b9ef0f75173482a2912355fd71f8a8aa29e58f5b66a91909dc53c1cd269ab2bc569bad62a67f6c
DIST dask-2022.9.2.gh.tar.gz 8767605 BLAKE2B ad0d9b7f849f984316768f1d1983e13177c3263b6803ce6d861b15b8d88c21c7dce4dae917ca28f8688797573503c6fd518816ca7d993d67c56172ef2adc73ec SHA512 467411933432821413f8440e6434b18c2bf76c616a92ec990bc71c141ea2cab235c1330e888ed77f429b6d00d588042928cd3b06d9b693d51302cf8c114700dd
+EBUILD dask-2022.10.0.ebuild 1780 BLAKE2B 0af473bd7b44c26022591b631cae4f656a861b33cd415b78336658692d589712373058e7e82bf288959df7819ade2b941af7c84bdea97bf40ba20489e4fd78f6 SHA512 de374eabcd08502dde1c0a39819e21cac7903756bfcaff74d83cc75be2341c2e67359f25ad2d255978a3dc71e8fcc519a762c519c6051d6a942343abd7505aab
EBUILD dask-2022.9.0.ebuild 1779 BLAKE2B 4dea87e8411ff0ecb0aa0f647a0ca84f6b95f3289be3e9cf232bb66108bc1ecfbda8327960712df44cbdf1dcc6713c1a11cc3294ac6d8df7a700de5c058d9fd7 SHA512 4de6ded112a26208ef4c4ac039a2aa55464a47431d48b040c198e0e3fba3dc167af2a8786220cc8b1744ee2ffcaa0869eba90c187f1c481aa89e2fc5604f2f84
EBUILD dask-2022.9.1.ebuild 1780 BLAKE2B 0af473bd7b44c26022591b631cae4f656a861b33cd415b78336658692d589712373058e7e82bf288959df7819ade2b941af7c84bdea97bf40ba20489e4fd78f6 SHA512 de374eabcd08502dde1c0a39819e21cac7903756bfcaff74d83cc75be2341c2e67359f25ad2d255978a3dc71e8fcc519a762c519c6051d6a942343abd7505aab
EBUILD dask-2022.9.2.ebuild 1780 BLAKE2B 0af473bd7b44c26022591b631cae4f656a861b33cd415b78336658692d589712373058e7e82bf288959df7819ade2b941af7c84bdea97bf40ba20489e4fd78f6 SHA512 de374eabcd08502dde1c0a39819e21cac7903756bfcaff74d83cc75be2341c2e67359f25ad2d255978a3dc71e8fcc519a762c519c6051d6a942343abd7505aab
diff --git a/dev-python/dask/dask-2022.10.0.ebuild b/dev-python/dask/dask-2022.10.0.ebuild
new file mode 100644
index 000000000000..6ad6f0bd45e1
--- /dev/null
+++ b/dev-python/dask/dask-2022.10.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="
+ https://www.dask.org/
+ https://github.com/dask/dask/
+ https://pypi.org/project/dask/
+"
+SRC_URI="
+ https://github.com/dask/dask/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/cloudpickle-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.15.1[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ >=dev-python/partd-0.3.10[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.8.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ test? (
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # another test relying on -Werror
+ "dask/array/tests/test_overlap.py::test_map_overlap_no_depth[None]"
+ # TODO
+ dask/array/tests/test_reductions.py::test_mean_func_does_not_warn
+ dask/tests/test_config.py::test__get_paths
+ dask/array/tests/test_linalg.py::test_solve_assume_a
+ "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>0-float-5-1-True]"
+ "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>1-float-5-1-True]"
+)
+
+python_test() {
+ epytest -p no:flaky -m "not network"
+}