summaryrefslogtreecommitdiff
path: root/dev-python/dask
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-21 07:53:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-21 07:53:35 +0000
commite393c0503a79342594a61547dc43f80f8bcc086e (patch)
tree3254e8166c98b932add34913169c98f7b7f9fa5f /dev-python/dask
parentb46782805d0eed36ce9685f7e9abf25671f24d7d (diff)
gentoo auto-resync : 21:12:2022 - 07:53:34
Diffstat (limited to 'dev-python/dask')
-rw-r--r--dev-python/dask/Manifest1
-rw-r--r--dev-python/dask/dask-2022.12.1-r1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index 4caa283570b4..7785d196a9ac 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -5,5 +5,6 @@ DIST dask-2022.12.1.gh.tar.gz 8233697 BLAKE2B 90caeb7a8a9abc03b035c787ae2f26d5da
EBUILD dask-2022.10.1.ebuild 1779 BLAKE2B d7794dc3a690c8742b885b288c7600e2696246f9614f7c7f17f033f43ca864c5b22377d4c1d9a628661206b0765fdd0dbeed53d4d6cae31970dc30f3ec34dbc7 SHA512 6b49452b4764b0585bca056eacce39e41390c1de9844187466ed2e97ff23bef9ad19fc8eb8222d5abf545c125a7d39cff4916ff890b09d0dd7e177ccba01e4ed
EBUILD dask-2022.11.1.ebuild 1780 BLAKE2B 24148b6128c95f1b700b3a5f1d53cf1e05147bc234a7092d8d64991c99af531e18664e413d4c35124f6062a25f32da5112846297650c54d719f48a5aa7cd3761 SHA512 559f6e575414a68c1e2db39a355120abd40d60d17ac9bda60919d508e0414776c5a0abeea2e70adf6f19a6039edf101dd20cbccd9079b18cc2b7dcef9f6ad767
EBUILD dask-2022.12.0.ebuild 1780 BLAKE2B 24148b6128c95f1b700b3a5f1d53cf1e05147bc234a7092d8d64991c99af531e18664e413d4c35124f6062a25f32da5112846297650c54d719f48a5aa7cd3761 SHA512 559f6e575414a68c1e2db39a355120abd40d60d17ac9bda60919d508e0414776c5a0abeea2e70adf6f19a6039edf101dd20cbccd9079b18cc2b7dcef9f6ad767
+EBUILD dask-2022.12.1-r1.ebuild 1781 BLAKE2B 819d3197a8db6e83ad410c837d68864fe023039072b7b7cf89fd3ab4972e4da7102a8673df9cc50c25234e982f973f3fb73346d568c31f0c879c823ffae2d613 SHA512 3f46b4680fb6078ea54c9c5bb2764601cbaf01d5d98159e7e174580668766414cfb730e0fade70fd9d7452011ab9d085fe369e977fc4c9f3a2d8f8d744719406
EBUILD dask-2022.12.1.ebuild 1780 BLAKE2B 24148b6128c95f1b700b3a5f1d53cf1e05147bc234a7092d8d64991c99af531e18664e413d4c35124f6062a25f32da5112846297650c54d719f48a5aa7cd3761 SHA512 559f6e575414a68c1e2db39a355120abd40d60d17ac9bda60919d508e0414776c5a0abeea2e70adf6f19a6039edf101dd20cbccd9079b18cc2b7dcef9f6ad767
MISC metadata.xml 724 BLAKE2B 9af7553cec2b66228a21f146372d86b8d620048d68f94c1fd09006c8ee7ddaa4e212c2a359b937a5ee37ac23df01e10af0796e8b4cf952237cb4c73a2dff7ca0 SHA512 89b83402c13b06f7adf10cd1cc08b96b90dbc2ca3b5c0c6c422b6e2394e03fd51346306479557c11fcfdbd4a81a574890f2367228ea38531b5f05c02a30b8dcb
diff --git a/dev-python/dask/dask-2022.12.1-r1.ebuild b/dev-python/dask/dask-2022.12.1-r1.ebuild
new file mode 100644
index 000000000000..c9b6b990f462
--- /dev/null
+++ b/dev-python/dask/dask-2022.12.1-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="
+ https://www.dask.org/
+ https://github.com/dask/dask/
+ https://pypi.org/project/dask/
+"
+SRC_URI="
+ https://github.com/dask/dask/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/cloudpickle-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.15.1[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ >=dev-python/partd-0.3.10[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.8.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ test? (
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # another test relying on -Werror
+ "dask/array/tests/test_overlap.py::test_map_overlap_no_depth[None]"
+ # TODO
+ dask/array/tests/test_reductions.py::test_mean_func_does_not_warn
+ dask/tests/test_config.py::test__get_paths
+ dask/array/tests/test_linalg.py::test_solve_assume_a
+ "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>0-float-5-1-True]"
+ "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>1-float-5-1-True]"
+)
+
+python_test() {
+ epytest -p no:flaky -m "not network"
+}