summaryrefslogtreecommitdiff
path: root/dev-python/dask
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-30 11:39:43 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-30 11:39:43 +0100
commitc417025a2ab386cddabb71ad598a9b75b47af313 (patch)
tree65963e1f2e99ed22f278cdb819bb1d0892062731 /dev-python/dask
parent49fadb6686800eac5ce039896df6437ac7240c8c (diff)
gentoo auto-resync : 30:09:2023 - 11:39:43
Diffstat (limited to 'dev-python/dask')
-rw-r--r--dev-python/dask/Manifest2
-rw-r--r--dev-python/dask/dask-2023.9.3.ebuild87
2 files changed, 89 insertions, 0 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index 15ec652d4a78..2ce7449c8cc1 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -1,5 +1,7 @@
DIST dask-2023.9.1.gh.tar.gz 8544717 BLAKE2B 786ca3bda6b356acdeb56070964aa25e136f9976322ae5dbaf5895eb181fc1b7582ae4731de12e7881287433d4f502dbbc5002840ebc443403a9fa76df438693 SHA512 1bf0a028059dfba70a131648f4884a6c9a091cd2d550dc7968cb2a8728ce5ef405c351f100001ab2ce48470634577104924fdf4b6dadda32308b4b5a62b3200e
DIST dask-2023.9.2.gh.tar.gz 8544631 BLAKE2B bd0168d1ea86921235e7bd9ae3e6b9dc2abed3c3e300afea84fb3f2d462970ca5fa4d82f5479bc2c036d4f1a1ec9f63ff98151d8f339db2b14533be765b0f25f SHA512 ae7d289882d7e2e2ef46af3256cf69d8e443f5350f32088e33b46f37377fe8c8328de609d16d0a2abf4df5bc7671d88288968d3d18a535eaec1bfbf0a5adbcba
+DIST dask-2023.9.3.gh.tar.gz 8544054 BLAKE2B 4b1fc7d3b6f91fd6db0836a0fede0304e9c5e04e2aacd573eb06cf96ddf67ecbb198a185076ff94ca34216732673113e7e268482992b781777b3757d43a11773 SHA512 d91840f8a339ff0a21734726b1674c4dbc1332270fb160e01fd342b1ce1ba2fd5cea34c501c7a61e6b34e121da937701932a93ab85dc85618f5b5fc52cd960cd
EBUILD dask-2023.9.1.ebuild 2744 BLAKE2B 884fc6c815bbffac1bb368eb74efee3ecdfb13eb0d99115d41ce52581d44e748855701c3fe3927fe4b087c56cd090c4760e0547a8a93ebf854a11fd93fae6272 SHA512 3313fb9a15aca7b867bf8bc198a6aa963c8f52214a92b89744e582fcc4ca6587213c0d19ea83b3919a3e64c7668ae088eb63c1f56e881047ef5f9b561e3e3878
EBUILD dask-2023.9.2.ebuild 2745 BLAKE2B 16fc9fa5481e2d5a6578bd1e413a9f2d9325a70bdcb3cf27a67bf04a125b8f25c408caa7c8b03886c6da7df85a472918035caac495ac8a097fa9435bcec07836 SHA512 d41be063c2a4389045d5ae61ae82b43964791ae142232aad716e7938900670afa21a1a425721682e3799a6a308653838777452bedad150c2ce997b7c1217a977
+EBUILD dask-2023.9.3.ebuild 2840 BLAKE2B d21d219ebb8d6219bbcb9e3257de06b9539b86037410956d58c4fc1e33c3b2e724393ef9d79d660ba58c10ccc0f4cde6648be4620803db75f2e9e0aaa8c1223d SHA512 2e48cf018c518b4403b14009e3a5aa358a627a08e67fe600a20366019df4669628d500212e864f26d88b5f85178e5dfa007fed8e287a4c0e2090fc053196050a
MISC metadata.xml 724 BLAKE2B 9af7553cec2b66228a21f146372d86b8d620048d68f94c1fd09006c8ee7ddaa4e212c2a359b937a5ee37ac23df01e10af0796e8b4cf952237cb4c73a2dff7ca0 SHA512 89b83402c13b06f7adf10cd1cc08b96b90dbc2ca3b5c0c6c422b6e2394e03fd51346306479557c11fcfdbd4a81a574890f2367228ea38531b5f05c02a30b8dcb
diff --git a/dev-python/dask/dask-2023.9.3.ebuild b/dev-python/dask/dask-2023.9.3.ebuild
new file mode 100644
index 000000000000..532c80da9d4b
--- /dev/null
+++ b/dev-python/dask/dask-2023.9.3.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="
+ https://www.dask.org/
+ https://github.com/dask/dask/
+ https://pypi.org/project/dask/
+"
+SRC_URI="
+ https://github.com/dask/dask/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/click-8.0[${PYTHON_USEDEP}]
+ >=dev-python/cloudpickle-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.9.0[${PYTHON_USEDEP}]
+ >=dev-python/importlib-metadata-4.13.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.21[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.3[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ >=dev-python/partd-1.2.0[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ >=dev-python/versioneer-0.28[${PYTHON_USEDEP}]
+ test? (
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # fails with sqlalchemy-2.0, even though we don't use it x_x
+ sed -i -e '/RemovedIn20Warning/d' pyproject.toml || die
+ sed -i -e 's:--cov-config=pyproject.toml::' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # more tests relying on -Werror
+ "dask/array/tests/test_overlap.py::test_map_overlap_no_depth[None]"
+ dask/array/tests/test_random.py::test_RandomState_only_funcs
+ # TODO
+ dask/array/tests/test_reductions.py::test_mean_func_does_not_warn
+ dask/tests/test_config.py::test__get_paths
+ dask/array/tests/test_linalg.py::test_solve_assume_a
+ "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>0-float-5-1-True]"
+ "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>1-float-5-1-True]"
+ dask/array/tests/test_image.py::test_preprocess
+ dask/tests/test_system.py::test_cpu_count_cgroups_v2
+ # require sqlalchemy<2.0
+ dask/dataframe/io/tests/test_sql.py
+ )
+
+ if ! has_version -b "dev-python/pyarrow[parquet,${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ # fails if pyarrow is installed without USE=parquet
+ # (optional dep, skipped if it's not installed at all)
+ dask/dataframe/io/tests/test_parquet.py::test_pyarrow_filter_divisions
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_rerunfailures -m "not network" \
+ -p xdist -n "$(makeopts_jobs)"
+}