summaryrefslogtreecommitdiff
path: root/dev-python/daemonize/daemonize-2.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
commit7c59acba5699c9c58090a7a738669669a7307023 (patch)
treed51d27d020895a6b7a3298d9d1b9846c1fcb59a0 /dev-python/daemonize/daemonize-2.5.0.ebuild
parente2db47eaae00ec33f8971db44b68645c5d3b9590 (diff)
gentoo resync : 21.08.2021
Diffstat (limited to 'dev-python/daemonize/daemonize-2.5.0.ebuild')
-rw-r--r--dev-python/daemonize/daemonize-2.5.0.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/daemonize/daemonize-2.5.0.ebuild b/dev-python/daemonize/daemonize-2.5.0.ebuild
index ace9fe951e98..c173bf76ab7d 100644
--- a/dev-python/daemonize/daemonize-2.5.0.ebuild
+++ b/dev-python/daemonize/daemonize-2.5.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -14,3 +14,7 @@ SRC_URI="https://github.com/thesharp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+
+python_test() {
+ "${EPYTHON}" tests/test.py -v || die "Tests failed with ${EPYTHON}"
+}