summaryrefslogtreecommitdiff
path: root/dev-python/cython-test-exception-raiser/cython-test-exception-raiser-1.0.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/cython-test-exception-raiser/cython-test-exception-raiser-1.0.2-r1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/cython-test-exception-raiser/cython-test-exception-raiser-1.0.2-r1.ebuild')
-rw-r--r--dev-python/cython-test-exception-raiser/cython-test-exception-raiser-1.0.2-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/cython-test-exception-raiser/cython-test-exception-raiser-1.0.2-r1.ebuild b/dev-python/cython-test-exception-raiser/cython-test-exception-raiser-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..b5683d93cb1d
--- /dev/null
+++ b/dev-python/cython-test-exception-raiser/cython-test-exception-raiser-1.0.2-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A trivial extension that just raises an exception (for testing)"
+HOMEPAGE="
+ https://pypi.org/project/cython-test-exception-raiser/
+ https://github.com/twisted/cython-test-exception-raiser/"
+SRC_URI="
+ https://github.com/twisted/cython-test-exception-raiser/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"