summaryrefslogtreecommitdiff
path: root/dev-python/cypari2/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-16 12:22:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-16 12:22:56 +0100
commit2ca31eebd5b7496656193e0aa6ae39200d69a017 (patch)
tree6cf0c8f4ce90a3960c27acf45011134fb674dd62 /dev-python/cypari2/files
parent3ad1879f00b279af69d6b9cd3ef97a2a7496d734 (diff)
gentoo auto-resync : 16:08:2024 - 12:22:56
Diffstat (limited to 'dev-python/cypari2/files')
-rw-r--r--dev-python/cypari2/files/cypari2-2.2.0-regen-bindings-for-each-python.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/cypari2/files/cypari2-2.2.0-regen-bindings-for-each-python.patch b/dev-python/cypari2/files/cypari2-2.2.0-regen-bindings-for-each-python.patch
new file mode 100644
index 000000000000..9e69c6e43121
--- /dev/null
+++ b/dev-python/cypari2/files/cypari2-2.2.0-regen-bindings-for-each-python.patch
@@ -0,0 +1,25 @@
+diff --git a/setup.py b/setup.py
+index c1775b5..5051c6b 100755
+--- a/setup.py
++++ b/setup.py
+@@ -12,6 +12,10 @@ from autogen.paths import include_dirs, library_dirs
+
+ ext_kwds = dict(include_dirs=include_dirs(), library_dirs=library_dirs())
+
++# Generate auto-generated sources from pari.desc
++# This needs to be done before build/build_ext so the generated pxd is moved
++# to the build directory and installed with newer setuptools.
++rebuild()
+
+ if "READTHEDOCS" in os.environ:
+ # When building with readthedocs, disable optimizations to decrease
+@@ -28,9 +32,6 @@ if "READTHEDOCS" in os.environ:
+ # Adapted from Cython's new_build_ext
+ class build_ext(_build_ext):
+ def finalize_options(self):
+- # Generate auto-generated sources from pari.desc
+- rebuild()
+-
+ self.directives = {
+ "autotestdict.cdef": True,
+ "binding": True,