summaryrefslogtreecommitdiff
path: root/dev-python/cwcwidth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /dev-python/cwcwidth
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'dev-python/cwcwidth')
-rw-r--r--dev-python/cwcwidth/Manifest5
-rw-r--r--dev-python/cwcwidth/cwcwidth-0.1.1.ebuild29
-rw-r--r--dev-python/cwcwidth/cwcwidth-0.1.2.ebuild29
-rw-r--r--dev-python/cwcwidth/metadata.xml11
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/cwcwidth/Manifest b/dev-python/cwcwidth/Manifest
new file mode 100644
index 000000000000..fc246eb09069
--- /dev/null
+++ b/dev-python/cwcwidth/Manifest
@@ -0,0 +1,5 @@
+DIST cwcwidth-0.1.1.gh.tar.gz 9054 BLAKE2B fb907d467a143851cc000061f9787f032788d7b684307341208ed498ade160bcd01d372ee2281fde7d1e1561aaa309d6d0bf9b776abaaef042f8b22e9df8d948 SHA512 b025af3a21d22634fe154f32fdbf380eb56d085e247147b2d0031ca36ef9d8de68aaae8133e611ec3bb36e2bc69f384e3dc23654abde2cb8b715305ba26cb66d
+DIST cwcwidth-0.1.2.gh.tar.gz 9490 BLAKE2B 3bb2e918361eef7887ec3684ad1414a0db109326f435e61fb1e00a52edbda8a6575bc748dc40967c861c08b5707d7389877a87cadf5ae6af9244e86b156eca1b SHA512 897eae8369bbfd52894f3dbd488c0987298ba9a928739c9ecd711a55e189accf3ec0b6c0e4db9458bb363e71cb0804bf97eb9118509a5d8da5b6bd02fde177a2
+EBUILD cwcwidth-0.1.1.ebuild 575 BLAKE2B 76ecb01cce5e4e615e06cd1d7f9792e5ab3798d1ef72bf18bc6670fe21be631aacb54a61cfb4c478650dcc1e54eec9b792856073a00c21a8f1147de7bb5ba99b SHA512 4575a64e49bdaa1571d607fb90cf36ae773a0db946c2465b6555ee5c77360ed446a6ee2c89525dbf1ca95cdb8088132bc16ff988afbbcdc1cd06b7304dbc7161
+EBUILD cwcwidth-0.1.2.ebuild 575 BLAKE2B 76ecb01cce5e4e615e06cd1d7f9792e5ab3798d1ef72bf18bc6670fe21be631aacb54a61cfb4c478650dcc1e54eec9b792856073a00c21a8f1147de7bb5ba99b SHA512 4575a64e49bdaa1571d607fb90cf36ae773a0db946c2465b6555ee5c77360ed446a6ee2c89525dbf1ca95cdb8088132bc16ff988afbbcdc1cd06b7304dbc7161
+MISC metadata.xml 348 BLAKE2B 391d997dbacbacd001676563eb369d85e0e95c97b6f10e00aa51ab6b3f88bf4a7c352105075ee9ca1f2a4e96a7e1831a55cccb2ca01166d6cdbbedf485db287b SHA512 912096776825111301ecfc80febe6297b9146ee57a9861c7a7ae6700aaf9eabb2b494fb3398e1fbb4ef1cae37e9fcbec97de875be1cb1cf3ebb4ecc4b59beae6
diff --git a/dev-python/cwcwidth/cwcwidth-0.1.1.ebuild b/dev-python/cwcwidth/cwcwidth-0.1.1.ebuild
new file mode 100644
index 000000000000..fc41a3538ac6
--- /dev/null
+++ b/dev-python/cwcwidth/cwcwidth-0.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for wc(s)width"
+HOMEPAGE="
+ https://github.com/sebastinas/cwcwidth/
+ https://pypi.org/project/cwcwidth/"
+SRC_URI="
+ https://github.com/sebastinas/cwcwidth/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+src_test() {
+ cd tests || die
+ distutils-r1_src_test
+}
diff --git a/dev-python/cwcwidth/cwcwidth-0.1.2.ebuild b/dev-python/cwcwidth/cwcwidth-0.1.2.ebuild
new file mode 100644
index 000000000000..fc41a3538ac6
--- /dev/null
+++ b/dev-python/cwcwidth/cwcwidth-0.1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for wc(s)width"
+HOMEPAGE="
+ https://github.com/sebastinas/cwcwidth/
+ https://pypi.org/project/cwcwidth/"
+SRC_URI="
+ https://github.com/sebastinas/cwcwidth/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+src_test() {
+ cd tests || die
+ distutils-r1_src_test
+}
diff --git a/dev-python/cwcwidth/metadata.xml b/dev-python/cwcwidth/metadata.xml
new file mode 100644
index 000000000000..9a01d15c55f6
--- /dev/null
+++ b/dev-python/cwcwidth/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">sebastinas/cwcwidth</remote-id>
+ <remote-id type="pypi">cwcwidth</remote-id>
+ </upstream>
+</pkgmetadata>