summaryrefslogtreecommitdiff
path: root/dev-python/ctypescrypto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/ctypescrypto
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/ctypescrypto')
-rw-r--r--dev-python/ctypescrypto/Manifest4
-rw-r--r--dev-python/ctypescrypto/ctypescrypto-0.5.ebuild41
-rw-r--r--dev-python/ctypescrypto/ctypescrypto-9999.ebuild41
-rw-r--r--dev-python/ctypescrypto/metadata.xml14
4 files changed, 100 insertions, 0 deletions
diff --git a/dev-python/ctypescrypto/Manifest b/dev-python/ctypescrypto/Manifest
new file mode 100644
index 000000000000..990363cdeb47
--- /dev/null
+++ b/dev-python/ctypescrypto/Manifest
@@ -0,0 +1,4 @@
+DIST ctypescrypto-0.5.tar.gz 44667 BLAKE2B abf24a4a5dc5ea1d977427f781e44433aaeac716b4f1f8d6f23e7f8de7debae75cfff80e72c369b64b8b9299f4b058763d42c5f21cd499f9b5689481afa5a538 SHA512 96ca12145be503a5b343d936cde172039057e5a2308fb6f6f65e14fe859d4e98d93ffb996849e391cf0c474425ee6243fd4c7998b088938a21456965d135188f
+EBUILD ctypescrypto-0.5.ebuild 1082 BLAKE2B 488ec4389cefd798e4316d8fb3d5fb9fa1670d42ecd1d3e2632511ab0c7d3196879652616852b46c7152f83e5c41d3b16b3cac0a3351892b3eeee87902cae070 SHA512 6b0ab0a0d27b33e5e71b9627a3605f6d081216998182394be6df231030bc01e615c5ae112eb8073f60f1e2efd5519ede79e29a81862ac587aee72ce376ace95c
+EBUILD ctypescrypto-9999.ebuild 1082 BLAKE2B 488ec4389cefd798e4316d8fb3d5fb9fa1670d42ecd1d3e2632511ab0c7d3196879652616852b46c7152f83e5c41d3b16b3cac0a3351892b3eeee87902cae070 SHA512 6b0ab0a0d27b33e5e71b9627a3605f6d081216998182394be6df231030bc01e615c5ae112eb8073f60f1e2efd5519ede79e29a81862ac587aee72ce376ace95c
+MISC metadata.xml 425 BLAKE2B dc5497a725f4d7ce3118e6de7090649851ab489289173a21a687aff121ec731a4713c726aa462f54da58801dd9f53787ce480d93f657e0a4c48b69874b15202d SHA512 a0c956fffdd8fb67922d69df4b687537522c50aa685c5689ccaf216d789d00f2221ec1d3789f75dbedd5d204fbd2089cee03c7aef1db0fa3d43a7c88c7b77494
diff --git a/dev-python/ctypescrypto/ctypescrypto-0.5.ebuild b/dev-python/ctypescrypto/ctypescrypto-0.5.ebuild
new file mode 100644
index 000000000000..cc4b87b8afab
--- /dev/null
+++ b/dev-python/ctypescrypto/ctypescrypto-0.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5..7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to some openssl function based on ctypes module"
+HOMEPAGE="https://github.com/vbwagner/ctypescrypto"
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/vbwagner/ctypescrypto.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/vbwagner/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="gost test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="test? ( gost )"
+
+RDEPEND="gost? ( dev-libs/gost-engine:= )"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Remove failed tests
+ rm tests/testpkey.py || die "rm failed"
+ # Disable test
+ sed -i '/test_verify_by_filestore/i\\ @unittest.skip("disable")' \
+ tests/testx509.py || die "sed failed for tests/testx509.py"
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" -m unittest discover -v tests || die "tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/ctypescrypto/ctypescrypto-9999.ebuild b/dev-python/ctypescrypto/ctypescrypto-9999.ebuild
new file mode 100644
index 000000000000..cc4b87b8afab
--- /dev/null
+++ b/dev-python/ctypescrypto/ctypescrypto-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5..7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to some openssl function based on ctypes module"
+HOMEPAGE="https://github.com/vbwagner/ctypescrypto"
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/vbwagner/ctypescrypto.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/vbwagner/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="gost test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="test? ( gost )"
+
+RDEPEND="gost? ( dev-libs/gost-engine:= )"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Remove failed tests
+ rm tests/testpkey.py || die "rm failed"
+ # Disable test
+ sed -i '/test_verify_by_filestore/i\\ @unittest.skip("disable")' \
+ tests/testx509.py || die "sed failed for tests/testx509.py"
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" -m unittest discover -v tests || die "tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/ctypescrypto/metadata.xml b/dev-python/ctypescrypto/metadata.xml
new file mode 100644
index 000000000000..db19a33dccc6
--- /dev/null
+++ b/dev-python/ctypescrypto/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <use>
+ <flag name="gost">Build with support for GOST Message Authentication Code</flag>
+ </use>
+</pkgmetadata>