summaryrefslogtreecommitdiff
path: root/dev-python/cssutils/cssutils-1.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/cssutils/cssutils-1.0.2.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/cssutils/cssutils-1.0.2.ebuild')
-rw-r--r--dev-python/cssutils/cssutils-1.0.2.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/cssutils/cssutils-1.0.2.ebuild b/dev-python/cssutils/cssutils-1.0.2.ebuild
deleted file mode 100644
index bcb2600b3e7f..000000000000
--- a/dev-python/cssutils/cssutils-1.0.2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="A CSS Cascading Style Sheets library"
-HOMEPAGE="https://pypi.org/project/cssutils/ https://bitbucket.org/cthedot/cssutils http://cthedot.de/cssutils/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- # Disable test failing with dev-python/pyxml installed.
- if has_version dev-python/pyxml; then
- sed -e "s/test_linecol/_&/" \
- -i src/cssutils/tests/test_errorhandler.py \
- || die
- fi
-
- # requires old pbr, does it really?
- sed \
- -e '/tests_require/d' \
- -i setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- ln -s "${S}/sheets" "${BUILD_DIR}/sheets" || die
- # esetup.py test
- # exclude tests that connect to the network
- set -- nosetests \
- -e test_parseUrl -e test_handlers -P "${BUILD_DIR}/lib/cssutils/tests"
- echo "$@"
- "$@" || die "Testing failed with ${EPYTHON}"
-}