summaryrefslogtreecommitdiff
path: root/dev-python/crashtest/crashtest-0.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-03 09:11:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-03 09:11:25 +0000
commit06c8293a57349047e228438cc7936e7481ab9159 (patch)
tree6da8926004f93c8934f99c570e0953bd8fb2edf3 /dev-python/crashtest/crashtest-0.4.1.ebuild
parent670a2ef95331c60f32a0831bfe79445340356b0b (diff)
gentoo auto-resync : 03:11:2022 - 09:11:25
Diffstat (limited to 'dev-python/crashtest/crashtest-0.4.1.ebuild')
-rw-r--r--dev-python/crashtest/crashtest-0.4.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/crashtest/crashtest-0.4.1.ebuild b/dev-python/crashtest/crashtest-0.4.1.ebuild
new file mode 100644
index 000000000000..a51cf7380836
--- /dev/null
+++ b/dev-python/crashtest/crashtest-0.4.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library that makes exceptions handling and inspection easier"
+HOMEPAGE="
+ https://github.com/sdispater/crashtest/
+ https://pypi.org/project/crashtest/
+"
+SRC_URI="
+ https://github.com/sdispater/crashtest/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+distutils_enable_tests pytest