summaryrefslogtreecommitdiff
path: root/dev-python/coverage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-03 11:48:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-03 11:48:34 +0100
commit8e3f5a0e42ba2822463660764321da4ed3b52ef9 (patch)
tree592fbe4efd697b02230386727643ed18f3da6a7f /dev-python/coverage
parentb2b21ac05f4c298db348c97a3566bcf712492610 (diff)
gentoo auto-resync : 03:10:2023 - 11:48:34
Diffstat (limited to 'dev-python/coverage')
-rw-r--r--dev-python/coverage/Manifest2
-rw-r--r--dev-python/coverage/coverage-7.3.2.ebuild82
2 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/coverage/Manifest b/dev-python/coverage/Manifest
index 6178e2298b83..a8d769fcdf1e 100644
--- a/dev-python/coverage/Manifest
+++ b/dev-python/coverage/Manifest
@@ -1,3 +1,5 @@
DIST coverage-7.3.1.tar.gz 764806 BLAKE2B 7399c7df63d0a546e20797c52780376bb8f65578753ffae3bb15901bd4fb7b4c0d8360b2dbc445e038d226af9ddf0b39c38c16fa70d9690b62477e5e75dfb51d SHA512 deeeab41ca53cdda83fe233f63bcf14909b96dfa0710d882dcaa9f81f4884ef7b39aaf177f832ce0f66f1fb88ad4b97d37ef2adfa2540d551352ed48af1926b2
+DIST coverage-7.3.2.tar.gz 764541 BLAKE2B 5301a45a1618582d6b7bc1c887fdfdc7ef612082675b271e5ab840f2adc357c6a01f59ba5571e6dba61db61c85ee66d40af46b3509dfbf5c996fcf9fd6b2a614 SHA512 94e3b0bae2f84d31448a717f105e4f03e485a47d9498e73e86eca2f040d0980e514e3d9264f5349f70ea93fc985161d89156d0faa444d28cc7a07e51db4e1a46
EBUILD coverage-7.3.1.ebuild 2026 BLAKE2B 886fdfdcc5139439f217ff82edf89f77cd9899b208350ac6373b33f88d2cb46db6c7eb4a295f42dd096f9bcd74345adf9e8433b17608358e034672a19c41c71c SHA512 8b5f83577f9a9b6a49048ef7240abcdb4acc77d70a538cb7e5c16e98d408247e5ec70730c3dc197cd480e10e83d6dfb56d52fc648aeffcf4aee48b4d9957f091
+EBUILD coverage-7.3.2.ebuild 2034 BLAKE2B 5e4cf3e6145634a04ecc6c9dfb322afb01ba75d3eb89decad37ccf056326394252a3579921056bdf8e42f112a4c04ca8f8bf983f049ccef6c76d89b3ef9c3851 SHA512 42fcc4abb0253d296586eb96848d56ce5b9c25548f837e68eb1e0162ad7e843730d7bb6d93d86316620e1741ceddd2034a354e5e44286e90f1e1018700d9730a
MISC metadata.xml 771 BLAKE2B 38e9680d0851f70050aad987714a9dd2f95178b0bc3d794dc08726c0618d1ea98be32a413ac397f4b222e8a5d8fdc747b7f1677bcfe842bac4080537e85a03a9 SHA512 8c44c40348fe5d416d8b4016fe22cc9ae0b94fbaf181deb79aa737f87271992521b710c1208d0eeb7ef92d96fc8a7daac1ec6feb1ae081a80f13327b5b094064
diff --git a/dev-python/coverage/coverage-7.3.2.ebuild b/dev-python/coverage/coverage-7.3.2.ebuild
new file mode 100644
index 000000000000..1f84c952787b
--- /dev/null
+++ b/dev-python/coverage/coverage-7.3.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Code coverage measurement for Python"
+HOMEPAGE="
+ https://coverage.readthedocs.io/en/latest/
+ https://github.com/nedbat/coveragepy/
+ https://pypi.org/project/coverage/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+"
+BDEPEND="
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/unittest-mixins-1.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/addopts/s:-q -n auto::' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+test_tracer() {
+ local -x COVERAGE_TEST_TRACER=${1}
+ einfo " Testing with the ${COVERAGE_TEST_TRACER} tracer ..."
+ epytest tests
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO: fails because of additional "Terminated" print on SIGTERM
+ tests/test_concurrency.py::SigtermTest::test_sigterm_threading_saves_data
+ )
+ local EPYTEST_IGNORE=(
+ # pip these days insists on fetching build deps from Internet
+ tests/test_venv.py
+ )
+
+ "${EPYTHON}" igor.py zip_mods || die
+
+ local -x COVERAGE_TESTING=True
+ # TODO: figure out why they can't be imported inside test env
+ local -x COVERAGE_NO_CONTRACTS=1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=_hypothesis_pytestplugin,flaky.flaky_pytest_plugin,xdist.plugin
+
+ local prev_opt=$(shopt -p nullglob)
+ shopt -s nullglob
+ local c_ext=( "${BUILD_DIR}/install$(python_get_sitedir)"/coverage/*.so )
+ ${prev_opt}
+
+ if [[ -n ${c_ext} ]]; then
+ cp "${c_ext}" \
+ coverage/ || die
+ test_tracer c
+ rm coverage/*.so || die
+ else
+ test_tracer py
+ fi
+}