summaryrefslogtreecommitdiff
path: root/dev-python/coverage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-17 06:26:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-17 06:26:48 +0000
commit2e0bf408961ec1023d3db1fc5d687c233661ac26 (patch)
tree96c6e46af3c356d1fb470acdf72ada482bb293f8 /dev-python/coverage
parent48dbe17904ac8ee6f006488d8f21734b0d253db4 (diff)
gentoo auto-resync : 17:03:2023 - 06:26:48
Diffstat (limited to 'dev-python/coverage')
-rw-r--r--dev-python/coverage/Manifest2
-rw-r--r--dev-python/coverage/coverage-7.2.2.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/coverage/Manifest b/dev-python/coverage/Manifest
index 1123415c4b3e..3d473ee3e4df 100644
--- a/dev-python/coverage/Manifest
+++ b/dev-python/coverage/Manifest
@@ -1,5 +1,7 @@
DIST coverage-7.1.0.tar.gz 809785 BLAKE2B 3720aee79ecfdd6aa652b5198bad4d6b5827a85f1d58986eec51bab1e72800dac28eb0ebbeb15d547ef03694ca1397bec47c37a9233dc34b2d3d2a6a22a48274 SHA512 80920b337391e47f1e631ba8a892792b6d2c72e753ddf403222c6ad527637699889f29cfee40721949e5eeb6e7977f319635c44d79f58e7e19676d1165dfdde2
DIST coverage-7.2.1.tar.gz 812219 BLAKE2B bb6b482990b0620d7e264244a9e31ee44b37fe83436c1d7d016d20e36d9ecbea85a614a4142683757bb1284bfbe2a157fc4748b01c76b5495c5eca5834e9a848 SHA512 40a7f1d25c7100b8f2f4ba1f877c241f65e1f560cdad861dab05254a4e177de37615888441d47a6c2ebc525ad2b52b476da7111efe5583708f094dd3a1b39984
+DIST coverage-7.2.2.tar.gz 812407 BLAKE2B 901ed01eb8411e01c3386dcecccf975f4ac0e46c14fd2c6086bcf83647ff7e26deccb3926f173a207ef2851c0f8c5f99874659a1ba2e16f85b6eb9a1ac23142c SHA512 7d2ba6540ca42c3a72b65343348a64c58156bac915434249fd8740a6727ebf034590f62a5557f6b2f76e67ed1adc2a153ce61eee71f3bc903538c440e080e3e7
EBUILD coverage-7.1.0.ebuild 1879 BLAKE2B b23b76f71ed197fada5e15ea5987f5e352f016ef1744e664b76acf52b9424721d0ef30291ded16faf1bb41b19011edd3649210ff383579eae9baeeaa263fbdb8 SHA512 0c80cc5065ed1b2d1881a522bfc9690ecf86b3c2121cb5bd0307a78341b7974fdd737d576f2aac98488ae7c67641a255c3017f5ed655867101be28a07e78c6e8
EBUILD coverage-7.2.1.ebuild 1840 BLAKE2B f07c3f549bed3742ea7e32db73a74937a58721a70602d437089b523134e4174cb65d52f3e6261aa531d55271da979422933e358b96208ef36786773998ed4966 SHA512 f6656da1a9bf31d979174c8e69afdea17fe1eb545809829943037b778999f82dc5a2bac23f81977b230e3430111c79aec2324577bdd494f788388b0330670157
+EBUILD coverage-7.2.2.ebuild 1840 BLAKE2B f07c3f549bed3742ea7e32db73a74937a58721a70602d437089b523134e4174cb65d52f3e6261aa531d55271da979422933e358b96208ef36786773998ed4966 SHA512 f6656da1a9bf31d979174c8e69afdea17fe1eb545809829943037b778999f82dc5a2bac23f81977b230e3430111c79aec2324577bdd494f788388b0330670157
MISC metadata.xml 771 BLAKE2B 38e9680d0851f70050aad987714a9dd2f95178b0bc3d794dc08726c0618d1ea98be32a413ac397f4b222e8a5d8fdc747b7f1677bcfe842bac4080537e85a03a9 SHA512 8c44c40348fe5d416d8b4016fe22cc9ae0b94fbaf181deb79aa737f87271992521b710c1208d0eeb7ef92d96fc8a7daac1ec6feb1ae081a80f13327b5b094064
diff --git a/dev-python/coverage/coverage-7.2.2.ebuild b/dev-python/coverage/coverage-7.2.2.ebuild
new file mode 100644
index 000000000000..b83e4bdd6609
--- /dev/null
+++ b/dev-python/coverage/coverage-7.2.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Code coverage measurement for Python"
+HOMEPAGE="
+ https://coverage.readthedocs.io/en/latest/
+ https://github.com/nedbat/coveragepy/
+ https://pypi.org/project/coverage/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.{8..10})
+"
+BDEPEND="
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/unittest-mixins-1.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/^addopts/s:-q -n auto::' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+test_tracer() {
+ local -x COVERAGE_TEST_TRACER=${1}
+ einfo " Testing with the ${COVERAGE_TEST_TRACER} tracer ..."
+ epytest tests
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # pip these days insists on fetching build deps from Internet
+ tests/test_venv.py
+ )
+
+ "${EPYTHON}" igor.py zip_mods || die
+
+ local -x COVERAGE_TESTING=True
+ # TODO: figure out why they can't be imported inside test env
+ local -x COVERAGE_NO_CONTRACTS=1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=_hypothesis_pytestplugin,flaky.flaky_pytest_plugin,xdist.plugin
+
+ local prev_opt=$(shopt -p nullglob)
+ shopt -s nullglob
+ local c_ext=( "${BUILD_DIR}/install$(python_get_sitedir)"/coverage/*.so )
+ ${prev_opt}
+
+ if [[ -n ${c_ext} ]]; then
+ cp "${c_ext}" \
+ coverage/ || die
+ test_tracer c
+ rm coverage/*.so || die
+ else
+ test_tracer py
+ fi
+}