summaryrefslogtreecommitdiff
path: root/dev-python/coreapi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/coreapi
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/coreapi')
-rw-r--r--dev-python/coreapi/Manifest1
-rw-r--r--dev-python/coreapi/coreapi-2.3.3-r2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/coreapi/Manifest b/dev-python/coreapi/Manifest
index 057a256f8a1d..becaaedece83 100644
--- a/dev-python/coreapi/Manifest
+++ b/dev-python/coreapi/Manifest
@@ -1,3 +1,4 @@
DIST core-api-python-client-2.3.3.tar.gz 37470 BLAKE2B ce3f88e1608715eec06a50fa5df4cd331e90509d0b7e9ab275ccfb4b3b5216115539b7fcd70af64794f0ae50a5084873d2dbbd38c85cb8be3f319d6880f5993e SHA512 aeae3ace84c0ce61552236b83db28e47492f5ac17a0e216e1a8eeddaf67270b94127f7a40f8a37cc5051abe097555adfd690a7e6c8801524ca77c916bd451ab8
EBUILD coreapi-2.3.3-r1.ebuild 663 BLAKE2B 2cf29a394cf12cec99cffb07c6eada9e767240b81b462689beb07c146821c8516fe382a4e4439509cf2abd059a855e1d55f5e065ccb777feed44879f8ca59017 SHA512 0d3f99dc03f633ba7fa2f0b8a762fe5462c199141b783fe350db7631913373bcca27812be04987c3ed78ee9f0e3d22a5ef817dd8f5c8b9c2f836c81a6bb5b8e8
+EBUILD coreapi-2.3.3-r2.ebuild 700 BLAKE2B 4d4b7a6568c367545c50f4fed10066a404b5b47bd6a5309f7c49376ae99263071b705ce76fffc266897c7b265f864c14a1ca5bc60d4e494debd46cf10cfa614b SHA512 9bd3d671b4b0e7f7cc75012c1298c0907c022ef9e4109d436b26227020330a9380d83d07451df843a3ef9c0f31dac4b9bd61d09a2e5a3b94586903f207a70d7d
MISC metadata.xml 311 BLAKE2B da7a7d5b0f01a9c0f1237c2e2a03e161d28446ebe8ec9625c9abf02b6565a584efec28367c1887230c80106ad5321efe8caa6374ee1ada30ffff9ecc9c2c085e SHA512 50f0c4044a7605f00e92c2514ae286862b99fbfd06ccec4e6281757ab5014297c139dd5caac631b3742b5e3bb4af3e18791d0b2b340c0af8ae6696a31e71529c
diff --git a/dev-python/coreapi/coreapi-2.3.3-r2.ebuild b/dev-python/coreapi/coreapi-2.3.3-r2.ebuild
new file mode 100644
index 000000000000..02f186b758d1
--- /dev/null
+++ b/dev-python/coreapi/coreapi-2.3.3-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=python-client-${PV}
+DESCRIPTION="Python client library for Core API"
+HOMEPAGE="https://github.com/core-api/python-client"
+SRC_URI="
+ https://github.com/core-api/python-client/archive/${PV}.tar.gz
+ -> core-api-${MY_P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/coreschema[${PYTHON_USEDEP}]
+ dev-python/itypes[${PYTHON_USEDEP}]
+ dev-python/uritemplate[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest