summaryrefslogtreecommitdiff
path: root/dev-python/cookies/cookies-2.2.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/cookies/cookies-2.2.1-r1.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/cookies/cookies-2.2.1-r1.ebuild')
-rw-r--r--dev-python/cookies/cookies-2.2.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/cookies/cookies-2.2.1-r1.ebuild b/dev-python/cookies/cookies-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..7902a8e44f21
--- /dev/null
+++ b/dev-python/cookies/cookies-2.2.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{2_7,3_{5,6,7,8}} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Friendlier RFC 6265-compliant cookie parser/renderer"
+HOMEPAGE="https://gitlab.com/sashahart/cookies"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ # https://gitlab.com/sashahart/cookies/merge_requests/2
+ "${FILESDIR}/cookies-2.2.1-fix-warnings.patch"
+
+ "${FILESDIR}/cookies-2.2.1-tests.patch"
+)
+
+distutils_enable_tests pytest