summaryrefslogtreecommitdiff
path: root/dev-python/contourpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-11 09:29:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-11 09:29:30 +0000
commit7d6f532c36268a2a8f53fa33c8e547c59702faa6 (patch)
tree6fd7a5cb102e736fe8969482dbce6c8a98808f6f /dev-python/contourpy
parentb4899ed9fc78f45325ef4e2ebd460869e53a605d (diff)
gentoo auto-resync : 11:11:2022 - 09:29:30
Diffstat (limited to 'dev-python/contourpy')
-rw-r--r--dev-python/contourpy/Manifest2
-rw-r--r--dev-python/contourpy/contourpy-1.0.5.ebuild47
2 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/contourpy/Manifest b/dev-python/contourpy/Manifest
index bed4e76ca8f5..188f611374a6 100644
--- a/dev-python/contourpy/Manifest
+++ b/dev-python/contourpy/Manifest
@@ -1,5 +1,3 @@
-DIST contourpy-1.0.5.gh.tar.gz 12153420 BLAKE2B 1b3899831938c114480606f0c2ef2962248721884cd2be727f2bd11d12d322e7652c7b63860f4c5d8bd039a7e838f3f360dd1af017219caa97dfc63d69ef7e19 SHA512 47dc08f02920cb0ffc081f313dd041fa36e2fd0a81530374ae77adc288af13cf2c526fc1f45d06ef1c256c4c8fe243e0b36b54d3fff7d4f8bd6f9f4938d3c805
DIST contourpy-1.0.6.gh.tar.gz 12154065 BLAKE2B d0a621e10bc465a0ed4a20136e813435bb4d79bdd39b64d60676bb794430f2ce15b247e13e163e8e2f89c69ea6a5880dc8f3c8a49750c15e7bcb554aeefcbac1 SHA512 3b6301b414758d588015b745be723642554459df14277aa2eb2def7b5194e0a2b73b73ce8409bc40cda34095e13984d7a2dbc1f3a1dcf272766df92d1de1b5ef
-EBUILD contourpy-1.0.5.ebuild 1057 BLAKE2B 062f767b633399ea1063b78ae410b91bb0477be467dbabe020ec19128d513af79113c6bcf9d907435697b5d78b2962907f7d439061d55e25343185272f01dc29 SHA512 2f2776062ce857043dbdecfd4ac3590ff3bcab65a8a866a816fabdb69502a8cc739b82b72d3860e9cf137f0269ac7736d04886de4fe5e5526aba3c84bce3db15
EBUILD contourpy-1.0.6.ebuild 1057 BLAKE2B 062f767b633399ea1063b78ae410b91bb0477be467dbabe020ec19128d513af79113c6bcf9d907435697b5d78b2962907f7d439061d55e25343185272f01dc29 SHA512 2f2776062ce857043dbdecfd4ac3590ff3bcab65a8a866a816fabdb69502a8cc739b82b72d3860e9cf137f0269ac7736d04886de4fe5e5526aba3c84bce3db15
MISC metadata.xml 372 BLAKE2B de3d6cc9d8727bf43be63fdbb8aa2ad375667d189019e189be262e39d028acab98a21e200798c2d5c5c72521aa7d38202e3e235dd44de9b43a7dc9e045d50c47 SHA512 e692f94d805d7f56fc895a4c76dfbacf2f068d687b9191482b946445baa3bd0a685eda7a1b0aec2aaf9a02e6f23d87f0bf22d90f42e3c21d930724c635ff859a
diff --git a/dev-python/contourpy/contourpy-1.0.5.ebuild b/dev-python/contourpy/contourpy-1.0.5.ebuild
deleted file mode 100644
index 972f9f2d56d9..000000000000
--- a/dev-python/contourpy/contourpy-1.0.5.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library for calculating contours in 2D quadrilateral grids"
-HOMEPAGE="
- https://pypi.org/project/contourpy/
- https://github.com/contourpy/contourpy/
-"
-SRC_URI="
- https://github.com/contourpy/contourpy/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
-
-RDEPEND="
- >=dev-python/numpy-1.16[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/pybind11-2.6[${PYTHON_USEDEP}]
- test? (
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_IGNORE=(
- # linters
- tests/test_codebase.py
- )
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- # threaded algorithms are known to be broken
- # https://github.com/contourpy/contourpy/issues/163
- epytest -k "not threaded and not threads"
-}