summaryrefslogtreecommitdiff
path: root/dev-python/construct/construct-2.9.45.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
commit62f67115b5c46134c34f88f4b1cbdacc19384c0a (patch)
tree0a76b14de203a4c23040e5665e39df8de9867745 /dev-python/construct/construct-2.9.45.ebuild
parent265dbe5dbc14c199299496c6db8fce3f76647015 (diff)
gentoo resync : 30.09.2018
Diffstat (limited to 'dev-python/construct/construct-2.9.45.ebuild')
-rw-r--r--dev-python/construct/construct-2.9.45.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/construct/construct-2.9.45.ebuild b/dev-python/construct/construct-2.9.45.ebuild
new file mode 100644
index 000000000000..d1968273fd4a
--- /dev/null
+++ b/dev-python/construct/construct-2.9.45.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A powerful declarative parser for binary data"
+HOMEPAGE="http://construct.readthedocs.io/ https://pypi.org/project/construct/"
+SRC_URI="https://github.com/construct/construct/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test"
+
+DEPEND="test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/scimath[${PYTHON_USEDEP}]' 'python2_7')
+ )"
+
+python_test() {
+ pytest -vv || die "Tests failed under ${EPYTHON}"
+}
+
+pkg_postinst() {
+ ewarn "Version 2.9.x has significant API and implementation changes from"
+ ewarn "previous 2.8.x releases. Please read the documentation at"
+ ewarn "https://construct.readthedocs.io/en/latest/transition29.html"
+ ewarn "for more info."
+}