summaryrefslogtreecommitdiff
path: root/dev-python/constantly/constantly-15.1.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/constantly/constantly-15.1.0-r2.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/constantly/constantly-15.1.0-r2.ebuild')
-rw-r--r--dev-python/constantly/constantly-15.1.0-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/constantly/constantly-15.1.0-r2.ebuild b/dev-python/constantly/constantly-15.1.0-r2.ebuild
new file mode 100644
index 000000000000..2a518fc02581
--- /dev/null
+++ b/dev-python/constantly/constantly-15.1.0-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Symbolic constants in Python"
+HOMEPAGE="https://github.com/twisted/constantly https://pypi.org/project/constantly/"
+SRC_URI="https://github.com/twisted/constantly/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? ( dev-python/twisted[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests setup.py