summaryrefslogtreecommitdiff
path: root/dev-python/confusable_homoglyphs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-29 15:34:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-10-29 15:34:19 +0000
commit67c78fc4ac5b7eada5a0196fa051b16628dac90c (patch)
treec3f41edf3185d25cbe9a93ad5ed6bb625f661e37 /dev-python/confusable_homoglyphs
parent704343381e435b306648a2d85a77a58e34478643 (diff)
gentoo auto-resync : 29:10:2023 - 15:34:19
Diffstat (limited to 'dev-python/confusable_homoglyphs')
-rw-r--r--dev-python/confusable_homoglyphs/Manifest4
-rw-r--r--dev-python/confusable_homoglyphs/confusable_homoglyphs-3.2.0-r2.ebuild26
2 files changed, 14 insertions, 16 deletions
diff --git a/dev-python/confusable_homoglyphs/Manifest b/dev-python/confusable_homoglyphs/Manifest
index d0aa4aed3a59..41f9b368f377 100644
--- a/dev-python/confusable_homoglyphs/Manifest
+++ b/dev-python/confusable_homoglyphs/Manifest
@@ -1,3 +1,3 @@
-DIST confusable_homoglyphs-3.2.0.gh.tar.gz 338272 BLAKE2B b4697ad3997ecb2784653a47779ead7ded0e9af46125bc5868954cc8cf5064377a553c9b388be6a42634fa27880ef2fa57224e4b4bf9e357b3a9ff32a5db4993 SHA512 6e51cc4ec9a70246f4a871b8303834d0189d9d5056823b2f576e198cc3ced7154a0d57e945f3814bfa37da6015808bc1d6cdf44cfa17d637ded83ead8a6e4f5c
-EBUILD confusable_homoglyphs-3.2.0-r2.ebuild 819 BLAKE2B 5dde6c66ebb63023fb9bf1f4dec6247f3d9fc1d862ec81ad29abbb5c9460aba6a1a6c697cf6622360df244fb6439a267e2d260a0595fe339107d7aedbdca319d SHA512 137f84ef9dd5c4e989733dfd4a74caa3a8f931f78f38480ec79971291a605b78722651cef54416d8ed8c13cbe2abdd18638f55fdbe4b00db026324136e111ca4
+DIST confusable_homoglyphs-3.2.0.tar.gz 161937 BLAKE2B ac2c66317b18dd73868b3cbe3b11162550597547da8ee3df5525362b79bd7f61a19bd7446839dfb477d5c2b27464fc88a120c5c6d496de8b86c9e88aabd8aeb0 SHA512 0a46a5bc94393592f6fa088bbe2f95cc301972c55de08231f3607828fcd3c5cb462514b80013283ef8cd8d76eaa3e14258ac8f3433c9c2cd1a89bcebca8fa7f6
+EBUILD confusable_homoglyphs-3.2.0-r2.ebuild 700 BLAKE2B fa332bb95a7cb97b511309e4d44ca171b5b28166c7baaffb4a1d02424780536567e3391c56d3e03c654c055276195a311718f4597be701c1cfc78cac2d104ccf SHA512 2ef0ec93fb2f7465d8bedaa1fb37bdee74a0d3ede1e8b04f34cdc6859a9c2d937b3e3dc3bc06fc6d255a1b4f59cc2bcb8859c992818ce1e21c0885dbbed72e20
MISC metadata.xml 397 BLAKE2B fb2119e687bb411de4fb76a9fad0bf32aba1ec30275beb9ddd4a585842823f64c9f1b773dea1507243dbd10437794d0a7dd0e62a35a3d29f4712df4cd5e1f0bf SHA512 57eae9c159782afe8324775750a0591ba4f16216292ba4d831b17fc3d965fe5d7b46aa28e0674847d359799762775acf8c03ab5afe97d2697611d7ca3962d369
diff --git a/dev-python/confusable_homoglyphs/confusable_homoglyphs-3.2.0-r2.ebuild b/dev-python/confusable_homoglyphs/confusable_homoglyphs-3.2.0-r2.ebuild
index a9190b96610a..5d7ef0d9fa24 100644
--- a/dev-python/confusable_homoglyphs/confusable_homoglyphs-3.2.0-r2.ebuild
+++ b/dev-python/confusable_homoglyphs/confusable_homoglyphs-3.2.0-r2.ebuild
@@ -4,33 +4,31 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-inherit distutils-r1
+PYTHON_COMPAT=( python3_{10..12} )
-CommitId=14f43ddd74099520ddcda29fac557c27a28190e6
+inherit distutils-r1 pypi
DESCRIPTION="Detect confusable usage of unicode homoglyphs, prevent homograph attacks"
HOMEPAGE="
https://github.com/vhf/confusable_homoglyphs/
https://pypi.org/project/confusable_homoglyphs/
"
-SRC_URI="https://github.com/vhf/${PN}/archive/${CommitId}.tar.gz
- -> ${P}.gh.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
-RDEPEND="dev-python/click[${PYTHON_USEDEP}]"
-
-S="${WORKDIR}"/${PN}-${CommitId}
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/versioneer[${PYTHON_USEDEP}]
+"
distutils_enable_tests pytest
-python_prepare_all() {
- sed -i \
- -e "s:versioneer.get_version():\"${PV}\":" \
- setup.py \
- || die
- distutils-r1_python_prepare_all
+src_prepare() {
+ # removed outdated bundled version (for py3.12 compat)
+ rm versioneer.py || die
+ distutils-r1_src_prepare
}