summaryrefslogtreecommitdiff
path: root/dev-python/configupdater/configupdater-3.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-28 10:54:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-28 10:54:09 +0000
commit3e690338421a6b64f6f44aa03db7416d75e0633a (patch)
treecb3907b4dfbc040edc539fd00645e851b14084bb /dev-python/configupdater/configupdater-3.2.ebuild
parenta6f8a4117d60ec2919f9b312dcb0b7baa6c58ab9 (diff)
gentoo auto-resync : 28:11:2023 - 10:54:09
Diffstat (limited to 'dev-python/configupdater/configupdater-3.2.ebuild')
-rw-r--r--dev-python/configupdater/configupdater-3.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/configupdater/configupdater-3.2.ebuild b/dev-python/configupdater/configupdater-3.2.ebuild
new file mode 100644
index 000000000000..97c59d6aff57
--- /dev/null
+++ b/dev-python/configupdater/configupdater-3.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Parser like ConfigParser but for updating configuration files"
+HOMEPAGE="
+ https://github.com/pyscaffold/configupdater/
+ https://pypi.org/project/ConfigUpdater/
+"
+SRC_URI="
+ https://github.com/pyscaffold/configupdater/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT PSF-2 PYTHON"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+src_prepare() {
+ distutils-r1_src_prepare
+ sed -i -e '/--cov/d' setup.cfg || die
+}