summaryrefslogtreecommitdiff
path: root/dev-python/configupdater/configupdater-3.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/configupdater/configupdater-3.1.1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/configupdater/configupdater-3.1.1.ebuild')
-rw-r--r--dev-python/configupdater/configupdater-3.1.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/configupdater/configupdater-3.1.1.ebuild b/dev-python/configupdater/configupdater-3.1.1.ebuild
new file mode 100644
index 000000000000..bb6d09e8a58f
--- /dev/null
+++ b/dev-python/configupdater/configupdater-3.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Parser like ConfigParser but for updating configuration files"
+HOMEPAGE="
+ https://github.com/pyscaffold/configupdater/
+ https://pypi.org/project/ConfigUpdater/
+"
+SRC_URI="
+ https://github.com/pyscaffold/configupdater/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT PSF-2 PYTHON"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+src_prepare() {
+ distutils-r1_src_prepare
+ sed -i -e '/--cov/d' setup.cfg || die
+}