summaryrefslogtreecommitdiff
path: root/dev-python/configshell-fb/configshell-fb-1.1.30.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-28 07:37:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-28 07:37:01 +0100
commit1a39e197a344b8ec7e3ed6c173bdf2a1ccba5b6b (patch)
tree7e7d76b763f13b5096b3bbb3b164edc87dc72b27 /dev-python/configshell-fb/configshell-fb-1.1.30.ebuild
parentdab47ccc26a61cb1fa68f2ab787233a1d12af4d1 (diff)
gentoo auto-resync : 28:06:2023 - 07:37:01
Diffstat (limited to 'dev-python/configshell-fb/configshell-fb-1.1.30.ebuild')
-rw-r--r--dev-python/configshell-fb/configshell-fb-1.1.30.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/configshell-fb/configshell-fb-1.1.30.ebuild b/dev-python/configshell-fb/configshell-fb-1.1.30.ebuild
new file mode 100644
index 000000000000..36b81de5ff30
--- /dev/null
+++ b/dev-python/configshell-fb/configshell-fb-1.1.30.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python library for building configuration shells"
+HOMEPAGE="
+ https://github.com/open-iscsi/configshell-fb/
+ https://pypi.org/project/configshell-fb/
+"
+SRC_URI="
+ https://github.com/open-iscsi/configshell-fb/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ "${EPYTHON}" examples/myshell || die "Test failed with ${EPYTHON}"
+}