summaryrefslogtreecommitdiff
path: root/dev-python/configshell-fb/configshell-fb-1.1.22.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/configshell-fb/configshell-fb-1.1.22.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/configshell-fb/configshell-fb-1.1.22.ebuild')
-rw-r--r--dev-python/configshell-fb/configshell-fb-1.1.22.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/configshell-fb/configshell-fb-1.1.22.ebuild b/dev-python/configshell-fb/configshell-fb-1.1.22.ebuild
new file mode 100644
index 000000000000..a9d5765390a5
--- /dev/null
+++ b/dev-python/configshell-fb/configshell-fb-1.1.22.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1 versionator
+
+MY_PV=$(replace_version_separator 2 '.fb' ${PV})
+
+DESCRIPTION="A Python library for building configuration shells"
+HOMEPAGE="https://github.com/open-iscsi/configshell-fb"
+SRC_URI="https://github.com/open-iscsi/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ !dev-python/configshell"
+
+S=${WORKDIR}/${PN}-${MY_PV}