summaryrefslogtreecommitdiff
path: root/dev-python/commonmark
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /dev-python/commonmark
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'dev-python/commonmark')
-rw-r--r--dev-python/commonmark/Manifest7
-rw-r--r--dev-python/commonmark/commonmark-0.5.4.ebuild36
-rw-r--r--dev-python/commonmark/commonmark-0.7.5.ebuild47
-rw-r--r--dev-python/commonmark/commonmark-0.8.1.ebuild43
-rw-r--r--dev-python/commonmark/metadata.xml19
5 files changed, 152 insertions, 0 deletions
diff --git a/dev-python/commonmark/Manifest b/dev-python/commonmark/Manifest
new file mode 100644
index 000000000000..1ddac91462eb
--- /dev/null
+++ b/dev-python/commonmark/Manifest
@@ -0,0 +1,7 @@
+DIST CommonMark-0.5.4.tar.gz 120316 BLAKE2B 47904d101d9d0e3759f82c28a4b80edfc0ed12cf0888e4915339118e496322cf0791d8a46d2edddca0d1794e82a9647cc22cbcfcc2d385a740c7c31cb8251659 SHA512 1983714a50a627f30f86af0d02dad9e52cb7b0ffce29691d0e740f587e599ead6de2412d72b895b7df772e1c81e171e56dfecaf593e611af65bd5798632a98ad
+DIST CommonMark-0.7.5.tar.gz 88702 BLAKE2B fc80d9e739d27f7e5dbf539b624c2fc2e700e61b17d0335c3234fc0fa0d3738e9117a8ca29e7a6bbaa6cd0d58b112defb6e19a7efce3ca57ca25c8ce67b2d3d2 SHA512 b0e3c4fea6c99b51c541054ecfe887935c2cc517a82df86da1d9cb4914189652326ec5b543cbbcb40ec43e5e09c285c47f5304ca1907764692e659c540591bdd
+DIST commonmark-0.8.1.tar.gz 90795 BLAKE2B 718c2b1af035672d74e2c6b6f89ea0cd23f45d7b0e47b6dadeef742d772f5458e08ec5f69fd4f34df9ab2c491d9d7add4c4acc7018c4048649aa0d8244d7db91 SHA512 dbab51d45c1973a8d0906148d785fb8ddc2b52177dfe0e69fe79bef2a5eb05a5a7ab8693852f4aaa8545af19d741569d04a24f06ea65171e6e80d9f66af47fdf
+EBUILD commonmark-0.5.4.ebuild 816 BLAKE2B 4623bcdc238c125819bf1abdc13d5784fa38002ff745d295b8570008bb265d60f5958de44ec7afa324af5bb3676fae2288881f1592863fb15a5f994916dbec84 SHA512 53d96ed5ab173d09aafc4a5001704f1bd29d5c3b9d20f8df9712a570504ccf24bdc75526c9f1b988bd7d5b46e7bf936838efecbb92d50c6e132ed1b033ce7879
+EBUILD commonmark-0.7.5.ebuild 1072 BLAKE2B 663fb0549b8dc91e3324db235612c655f28d0edcb50a9af1bb5e0bd8ddb34b3772cd0aa1901efe564cb1175f444a1f2a47c1f529f8af84cae8f5da8c21accd4a SHA512 68857c0969b7be6e7ae489cf63abdc77063b5368760b6aca4149733bf69bc2a3507664ad55642bf13203a0a79346f0a2745505d7eca901a8723b11c9a4be6b12
+EBUILD commonmark-0.8.1.ebuild 1004 BLAKE2B 601fee072353ca32a0c4daea40a3a4a57f1fdb0e3f44062bdb7f7d941ba0e5f84f7afde7ed2f074089d717503a0a89f170670c388d90c636b48ae3fb738d4a72 SHA512 3bb45d760e2f8cff6f582043d587f05d0a1fae49c163bfd708b51e5191e5a560ee9192f852f04ff4070ed72f7d38ad69388e963be52194e073ee45588195f4f0
+MISC metadata.xml 756 BLAKE2B b169766e4e9850c3586f1359fb0103bfeb27d494c3d20c2a502618a20a397ff9ba7e9f0d13d07829e59c1350e5ced938d58b726704d00d0499b3ac1c614952d6 SHA512 1a28755c041abef9cb797c8d9ea448a62a500a915ae9c4002a22f85886fbae62c2574675926e80e5ffdcacf3a3257fc9065a14d6495574c556288b334274b03c
diff --git a/dev-python/commonmark/commonmark-0.5.4.ebuild b/dev-python/commonmark/commonmark-0.5.4.ebuild
new file mode 100644
index 000000000000..630fd63052eb
--- /dev/null
+++ b/dev-python/commonmark/commonmark-0.5.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+MY_PN=CommonMark
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Python parser for the CommonMark Markdown spec"
+HOMEPAGE="https://github.com/rtfd/CommonMark-py"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/future[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+S=${WORKDIR}/${MY_P}
+
+# unrestrict for versions >= 0.7.2
+RESTRICT=test
+
+python_test() {
+ LC_ALL='en_US.utf8' LC_CTYPE='en_US.utf8' LANG=en_US.utf8 PYTHONIOENCODING=UTF-8 \
+ esetup.py test
+}
diff --git a/dev-python/commonmark/commonmark-0.7.5.ebuild b/dev-python/commonmark/commonmark-0.7.5.ebuild
new file mode 100644
index 000000000000..52faefc635f9
--- /dev/null
+++ b/dev-python/commonmark/commonmark-0.7.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+MY_PN=CommonMark
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Python parser for the CommonMark Markdown spec"
+HOMEPAGE="https://github.com/rtfd/CommonMark-py"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/future[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/hypothesis-3.7.1[${PYTHON_USEDEP}]
+ )
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ PYTHONIOENCODING='utf8' \
+ esetup.py test
+}
+
+src_prepare() {
+ default
+ # Fix file collision with app-text/cmark, see bug #627034
+ sed -i -e "s:'cmark\( = CommonMark.cmark\:main'\):'cmark.py\1:" \
+ setup.py || die
+}
+
+pkg_postinst() {
+ ewarn "/usr/bin/cmark has been renamed to /usr/bin/cmark.py due file"
+ ewarn "collision with app-text/cmark (see bug #627034)"
+}
diff --git a/dev-python/commonmark/commonmark-0.8.1.ebuild b/dev-python/commonmark/commonmark-0.8.1.ebuild
new file mode 100644
index 000000000000..68e34aca47df
--- /dev/null
+++ b/dev-python/commonmark/commonmark-0.8.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python parser for the CommonMark Markdown spec"
+HOMEPAGE="https://github.com/rtfd/CommonMark-py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/future[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/hypothesis-3.7.1[${PYTHON_USEDEP}]
+ )
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ PYTHONIOENCODING='utf8' \
+ esetup.py test
+}
+
+src_prepare() {
+ default
+ # Fix file collision with app-text/cmark, see bug #627034
+ sed -i -e "s:'cmark\( = commonmark.cmark\:main'\):'cmark.py\1:" \
+ setup.py || die
+}
+
+pkg_postinst() {
+ ewarn "/usr/bin/cmark has been renamed to /usr/bin/cmark.py due file"
+ ewarn "collision with app-text/cmark (see bug #627034)"
+}
diff --git a/dev-python/commonmark/metadata.xml b/dev-python/commonmark/metadata.xml
new file mode 100644
index 000000000000..fc5b696a8da1
--- /dev/null
+++ b/dev-python/commonmark/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Pure Python port of jgm’s commonmark.js, a Markdown parser and
+ renderer for the CommonMark specification, using only native
+ modules. Once both this project and the CommonMark specification
+ are stable we will release the first 1.0 version and attempt to
+ keep up to date with changes in commonmark.js.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">CommonMark</remote-id>
+ <remote-id type="github">rtfd/CommonMark.py</remote-id>
+ </upstream>
+</pkgmetadata>