summaryrefslogtreecommitdiff
path: root/dev-python/commonmark/commonmark-0.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /dev-python/commonmark/commonmark-0.8.1.ebuild
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'dev-python/commonmark/commonmark-0.8.1.ebuild')
-rw-r--r--dev-python/commonmark/commonmark-0.8.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/commonmark/commonmark-0.8.1.ebuild b/dev-python/commonmark/commonmark-0.8.1.ebuild
new file mode 100644
index 000000000000..68e34aca47df
--- /dev/null
+++ b/dev-python/commonmark/commonmark-0.8.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python parser for the CommonMark Markdown spec"
+HOMEPAGE="https://github.com/rtfd/CommonMark-py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/future[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/hypothesis-3.7.1[${PYTHON_USEDEP}]
+ )
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ PYTHONIOENCODING='utf8' \
+ esetup.py test
+}
+
+src_prepare() {
+ default
+ # Fix file collision with app-text/cmark, see bug #627034
+ sed -i -e "s:'cmark\( = commonmark.cmark\:main'\):'cmark.py\1:" \
+ setup.py || die
+}
+
+pkg_postinst() {
+ ewarn "/usr/bin/cmark has been renamed to /usr/bin/cmark.py due file"
+ ewarn "collision with app-text/cmark (see bug #627034)"
+}