summaryrefslogtreecommitdiff
path: root/dev-python/comm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-25 07:12:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-25 07:12:05 +0000
commit14a74a5f982f25582974c2ee235027a041aec36d (patch)
treedc57c37e535d9d67af9a5034c4748ec3698923b9 /dev-python/comm
parentb1b0997aac1e7f68389ed3e0f95d3ea9d92277e2 (diff)
gentoo auto-resync : 25:11:2022 - 07:12:04
Diffstat (limited to 'dev-python/comm')
-rw-r--r--dev-python/comm/Manifest2
-rw-r--r--dev-python/comm/comm-0.1.1.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/comm/Manifest b/dev-python/comm/Manifest
index 9e5ee65c534d..f30c2ba2f15b 100644
--- a/dev-python/comm/Manifest
+++ b/dev-python/comm/Manifest
@@ -1,3 +1,5 @@
DIST comm-0.1.0.tar.gz 5364 BLAKE2B 25715bce2ca51ef81de742ab04dd17120cab1f2f6d563ef566bbefda71daeafe5c2361a56944329d7549610c8c8fbe84100dc5e85f550eb93056d81eb7081f28 SHA512 075c1c1126d4de4321470de4e5cce5b6c9bcbe3f3cc1676f80a464bd559977816d92ce609b58884a195699e1f1713f535045f6070ecf2726e47ff61feedc66f0
+DIST comm-0.1.1.gh.tar.gz 5382 BLAKE2B 8749ae33ecead77c1e3e0130c7d68082ac465fb733ad0908cf42a91d5a1aeca90c987fc469bcf47b5a384e108bafadbe009368162507c8a751b9e16eb5bbc2b0 SHA512 31ce4a1f1f35a3e1790e5a9896fd3f453a952c5fb0de094286bb31b806138a6661b143c1beb076b6fb73328304768e52c0ae6015f040b0451540a2d850f9d448
EBUILD comm-0.1.0.ebuild 568 BLAKE2B ce67afca071ce2bdc0280c5c915b2a0344b5129b2570d37f2b1d405f9bd5b25bd2afea3b8fc0de604348b5f9b6083e507b8b96dfff3d2ad355f7ab7bd4dfeb2a SHA512 796b9dabac4f7fd608ac9f6f533f1824931f3661c2b642ebe2f521ff0e0744ce83aeb636192c4e36af65bfc364cd770f5ce575b90362d40a3956dab372e0fd4a
+EBUILD comm-0.1.1.ebuild 634 BLAKE2B 09e1358dd910f6912041008466cd325fe11c67d68db7509fdc20296a3e1b839c77c6568f80ad3a34373a3ae36235ed15c0d6c5a54980c2a38a81ddb5b49c70dd SHA512 c0b3b02afd4cc6d1b73854f05084ff389f8d5670f5880126b526d88189c435a8cfccbba0792351249097a7d23e73a6a1b1f79cd969f59e8ef33da244b04e57b7
MISC metadata.xml 384 BLAKE2B c122aaf6c2b9e6776b19efa2549030f0267c1d553f92862c5ecf21926f30a9c3cd7564434a573cca6fdbb85485eb49213b4d95100e8de2a29ced9c9c1fa81153 SHA512 b06853ad3cb1775ad70e44c48bca74bcf85c11715291974e7e3ee496344256fc57b91920812f19809e7cf14f6a7f7938531934d6a12740baec0dd984d5d48632
diff --git a/dev-python/comm/comm-0.1.1.ebuild b/dev-python/comm/comm-0.1.1.ebuild
new file mode 100644
index 000000000000..d6be1ccf71fd
--- /dev/null
+++ b/dev-python/comm/comm-0.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Python Comm implementation, for usage in ipykernel, xeus-python"
+HOMEPAGE="
+ https://pypi.org/project/comm/
+ https://github.com/ipython/comm/
+"
+SRC_URI="
+ https://github.com/ipython/comm/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc"
+
+RDEPEND="
+ >dev-python/traitlets-5.3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest