summaryrefslogtreecommitdiff
path: root/dev-python/comm/comm-0.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-08 21:16:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-08 21:16:36 +0000
commit750f865355947c40a4b93cd7a5db23eebc4e5080 (patch)
treed09084ef3a0baa1b4e6adbdbb4e85abc21f6650f /dev-python/comm/comm-0.1.2.ebuild
parentc51985271f4c8e0bc79728c6cecf15d6b6515914 (diff)
gentoo auto-resync : 08:12:2022 - 21:16:36
Diffstat (limited to 'dev-python/comm/comm-0.1.2.ebuild')
-rw-r--r--dev-python/comm/comm-0.1.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/comm/comm-0.1.2.ebuild b/dev-python/comm/comm-0.1.2.ebuild
new file mode 100644
index 000000000000..925b2290e5f0
--- /dev/null
+++ b/dev-python/comm/comm-0.1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Python Comm implementation, for usage in ipykernel, xeus-python"
+HOMEPAGE="
+ https://github.com/ipython/comm/
+ https://pypi.org/project/comm/
+"
+SRC_URI="
+ https://github.com/ipython/comm/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/traitlets-5.3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest