summaryrefslogtreecommitdiff
path: root/dev-python/colorful
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-17 14:57:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-17 14:57:38 +0000
commit5959c8510d12e770f9320c71e55b4419e49154ee (patch)
tree560c7460ed5e13f38e3e946871031d4caaebdd13 /dev-python/colorful
parent7278fa233720d99bfac63a408deeed0143a61dcc (diff)
gentoo auto-resync : 17:12:2023 - 14:57:38
Diffstat (limited to 'dev-python/colorful')
-rw-r--r--dev-python/colorful/Manifest3
-rw-r--r--dev-python/colorful/colorful-0.5.5.ebuild41
-rw-r--r--dev-python/colorful/metadata.xml25
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/colorful/Manifest b/dev-python/colorful/Manifest
new file mode 100644
index 000000000000..6ce32b11c6a4
--- /dev/null
+++ b/dev-python/colorful/Manifest
@@ -0,0 +1,3 @@
+DIST colorful-0.5.5.gh.tar.gz 366498 BLAKE2B a7ab5dfb7ddfbf6682b75d2ed35f3f4cb7c3826918742316d877a17cb58e639b5fa86d7906be4879e89a5a0e78a16ede7535ade3f9f890c67bfcf42a0d1c9d9c SHA512 dc5e372261bd308a82bd0446a885b4c63a5a5781540731407f1a364d2c5397fe950f96fef3be8ffeab80cf02010be9551ba5b8550930e3fed5173cdc28a69306
+EBUILD colorful-0.5.5.ebuild 938 BLAKE2B 4278e1209cda1abdc590e37c1e760eef3c6ae06dda36ea8e21740a6c4d3a13727d4d6201205ae4cfec9e4115767e9e49c1bccb3f1590ebe5a0c53dc1021bfcba SHA512 34ce08bf61439b997229d5add59574699d5e43fd18dc69959e33c2a7c058846dd80460c817f86d8d1688d94856027dc0f06703c252da2aadcc02f74314477dea
+MISC metadata.xml 828 BLAKE2B 68b782b4eca8e5c0bc591081526933afad4d81d53fb0af3d1b1edf0bb9df8ae59f6448da15fc82abe83906db8a76ea69b898d04767fd0d98730d0dafaf65c4c9 SHA512 4ffb104301f58d5ce9a9ea2614b74f1b3caf28f37f319738a9f1ddb1c1da4537b82c95de5fb7ba77a39c54ba96125d9d1b3dd11e0e98bc6b7c802e5cd5057339
diff --git a/dev-python/colorful/colorful-0.5.5.ebuild b/dev-python/colorful/colorful-0.5.5.ebuild
new file mode 100644
index 000000000000..35e9e56ee19c
--- /dev/null
+++ b/dev-python/colorful/colorful-0.5.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Terminal string styling done right, in Python"
+HOMEPAGE="
+ https://pypi.org/project/colorful/
+ https://github.com/timofurrer/colorful/
+"
+SRC_URI="
+ https://github.com/timofurrer/colorful/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # Fix QA_issue python package discovery
+ # https://github.com/timofurrer/colorful/pull/53
+ sed -i \
+ -e "s/find_packages/find_namespace_packages/" \
+ -e "s/(exclude=\['\*tests\*'\])/(exclude=\['\*tests\*'\, '\*examples\*'\])/" \
+ setup.py || die "Error fixing setup.py for >=PEP420"
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -s
+}
diff --git a/dev-python/colorful/metadata.xml b/dev-python/colorful/metadata.xml
new file mode 100644
index 000000000000..be5dd72ee646
--- /dev/null
+++ b/dev-python/colorful/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>foti.giuseppe@gmail.com</email>
+ <name>Giuseppe Foti</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Package used for styling terminal strings in Python scripts.
+ This package is used as a dependency in net-analyzer/pontos.
+ </longdescription>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">timofurrer/colorful</remote-id>
+ <remote-id type="pypi">colorful</remote-id>
+ </upstream>
+</pkgmetadata>