summaryrefslogtreecommitdiff
path: root/dev-python/colorama
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/colorama
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/colorama')
-rw-r--r--dev-python/colorama/Manifest2
-rw-r--r--dev-python/colorama/colorama-0.4.4.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/colorama/Manifest b/dev-python/colorama/Manifest
index af3d11e92258..eac8ddf48e0d 100644
--- a/dev-python/colorama/Manifest
+++ b/dev-python/colorama/Manifest
@@ -1,3 +1,5 @@
DIST colorama-0.4.3.github.tar.gz 107251 BLAKE2B e09e92171b6ea4b3db4801feaf794e9aeb4f2b3e57079907911cbb909167b192eb857f0b404fa45673bee3bc02c122326bd05091846755d7dbfd990a74c60a24 SHA512 ab41a2f95fe75de0b280c174c6166b86645e5cc675dcedf784fe15170aae630e831370527c9490342b77c7d088a023a48428a519b52ad1c70be58904742a94c8
+DIST colorama-0.4.4.github.tar.gz 109439 BLAKE2B cbf08d4bd26924e269fd8b2ae6f9c7ecec905907acb296ded52b6b9c473c1a3b88945563cf00d4ddbf01c5bbfc4244997da20b47051594ca86a632a33c29fed2 SHA512 35501915b79bfc5fe46a36f83790ecd79c82150d6b73a57cd55fbe6431ea5ed7a86676504af90147eeb3a963ffd16890e0220099df579a66f2d8f1f7494f862e
EBUILD colorama-0.4.3-r1.ebuild 1134 BLAKE2B 0377e8620f5bc23ab67a59486d79e1d5f3dd8b1e3be9975f77551f5cef630b6a14408f35c9de71a84ad937b1266cb032c8bbf985812d5da8234b9941990829ed SHA512 0d57febb0b14d32e9a33d9343001a8972315b9ae6f50590919a806687fceed866ae34529206012022c516644947de587fb27710a6b2c17f50672f3b33625f17c
+EBUILD colorama-0.4.4.ebuild 1134 BLAKE2B 0377e8620f5bc23ab67a59486d79e1d5f3dd8b1e3be9975f77551f5cef630b6a14408f35c9de71a84ad937b1266cb032c8bbf985812d5da8234b9941990829ed SHA512 0d57febb0b14d32e9a33d9343001a8972315b9ae6f50590919a806687fceed866ae34529206012022c516644947de587fb27710a6b2c17f50672f3b33625f17c
MISC metadata.xml 525 BLAKE2B ae9c4e561fa86ce37c1bc26140f3dd4267c37591df64060b0c355a78f566b0453d6f923dc6de0e92595bc4f932bbaa58a823c2c9b62f9b8ec3f38cd1730a067a SHA512 19e73cbbef7d9ee826eb4df24a23f1d1896e294209fec9a1a854e174b83aa7a948b3128a3a70db3f406aeb577b9b500f80f41d544baf053ff4460bf2e5cc2646
diff --git a/dev-python/colorama/colorama-0.4.4.ebuild b/dev-python/colorama/colorama-0.4.4.ebuild
new file mode 100644
index 000000000000..b68e32c85110
--- /dev/null
+++ b/dev-python/colorama/colorama-0.4.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="ANSI escape character sequences for colored terminal text & cursor positioning"
+HOMEPAGE="
+ https://pypi.org/project/colorama/
+ https://github.com/tartley/colorama
+"
+# https://github.com/tartley/colorama/pull/183
+SRC_URI="https://github.com/tartley/${PN}/archive/${PV}.tar.gz -> ${P}.github.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docinto examples
+ dodoc -r demos/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
+
+python_test() {
+ # Some tests require stdout to be a TTY
+ # https://github.com/tartley/colorama/issues/169
+ script -eqc "pytest -vv -s" /dev/null \
+ || die "tests failed with ${EPYTHON}"
+}