summaryrefslogtreecommitdiff
path: root/dev-python/cmd2/cmd2-0.8.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-python/cmd2/cmd2-0.8.9.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-python/cmd2/cmd2-0.8.9.ebuild')
-rw-r--r--dev-python/cmd2/cmd2-0.8.9.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/cmd2/cmd2-0.8.9.ebuild b/dev-python/cmd2/cmd2-0.8.9.ebuild
new file mode 100644
index 000000000000..e6467b0194eb
--- /dev/null
+++ b/dev-python/cmd2/cmd2-0.8.9.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Extra features for standard library's cmd module"
+HOMEPAGE="https://github.com/python-cmd2/cmd2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+# restrict tests because pyperclip is fairly unstable...
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/pyparsing-2.0.1[${PYTHON_USEDEP}]
+ dev-python/pyperclip[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/subprocess32[${PYTHON_USEDEP}]' 'python2*')
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ py.test -vv || die
+ ${EPYTHON} example/example.py --test example/exampleSession.txt || die
+}