summaryrefslogtreecommitdiff
path: root/dev-python/cloudscraper
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-16 18:25:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-16 18:25:06 +0000
commit7972abc05090180dcc09d2b16af4020ce1cd1841 (patch)
tree3e6e1c7ca86ab7d4e8dc45009f67403fc489ade9 /dev-python/cloudscraper
parente4ad5901ca8464ae513bd315a1c0349c2bd0986c (diff)
gentoo auto-resync : 16:03:2023 - 18:25:06
Diffstat (limited to 'dev-python/cloudscraper')
-rw-r--r--dev-python/cloudscraper/Manifest2
-rw-r--r--dev-python/cloudscraper/cloudscraper-1.2.68.ebuild55
2 files changed, 0 insertions, 57 deletions
diff --git a/dev-python/cloudscraper/Manifest b/dev-python/cloudscraper/Manifest
index eb8f41de353b..afb8bfe4b93b 100644
--- a/dev-python/cloudscraper/Manifest
+++ b/dev-python/cloudscraper/Manifest
@@ -1,5 +1,3 @@
-DIST cloudscraper-1.2.68.gh.tar.gz 111952 BLAKE2B 69e896ad704ce776594fb89714bb75316ebff1b03387cba8575be6d60b496d18556690cfad109c2fa55c72ce3d91dcd21a21467a2d9820c579fea7482b688800 SHA512 42fa90127c6348c52a8327728683719966ae69c7b945cb9b485907e89e3b29b8053d31cd9cd4326e71ffd4c33e0fce20dd3d0e046fab62d89110eb4510535ad9
DIST cloudscraper-1.2.69.gh.tar.gz 112198 BLAKE2B ea7325353aa9c4bfaca1834a1f9fdb2201cee1946a990d059540500e58322899469a48d847b6d7688b8f671bf4bbe762d1f61ed080587f3a553771ba8e9c2a93 SHA512 9da8d3d42117768a0a38843448248e3a124c864aaa76d62125d3a1dad8ea4f1921954e6efaa2eb9b40c283d6889c15c0c33378db7008155e46ccb5ae219c11d6
-EBUILD cloudscraper-1.2.68.ebuild 1522 BLAKE2B 6114fc4c60872d61d24cf1822f900df5c6c0997572e0489a4edf8748bff71317b264846c8d7ae520fc5798571b79e4b691aace0389d06084fceb8c7f3620615c SHA512 6047e438a99db7e0e6df3301db05644f6f2405898cf81223f57c557f9f018389f7e9c1c260ffcda770e391f81baff9b89fd3f6f78b18cd12446fcb6a0b047bcb
EBUILD cloudscraper-1.2.69.ebuild 1522 BLAKE2B 6114fc4c60872d61d24cf1822f900df5c6c0997572e0489a4edf8748bff71317b264846c8d7ae520fc5798571b79e4b691aace0389d06084fceb8c7f3620615c SHA512 6047e438a99db7e0e6df3301db05644f6f2405898cf81223f57c557f9f018389f7e9c1c260ffcda770e391f81baff9b89fd3f6f78b18cd12446fcb6a0b047bcb
MISC metadata.xml 749 BLAKE2B dd73d528bd6b2fd50230028ca8877783b315c9f3327ca3173b75a32ca7d1dc6135aa86e765f6d7b9929e6a84e5ce7f99a9c2a0ee4972c01e818f27b83719b5b8 SHA512 b36231ae7509d4ee146c4b0ba97aef6d9ee67db44741ba9f53e201f5f6b0392eaee3ce6e41c988ef9938c5e4b6dbe1fea10505319d40916e6b0bce5597dd790c
diff --git a/dev-python/cloudscraper/cloudscraper-1.2.68.ebuild b/dev-python/cloudscraper/cloudscraper-1.2.68.ebuild
deleted file mode 100644
index de0d08b51d59..000000000000
--- a/dev-python/cloudscraper/cloudscraper-1.2.68.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="A Python module to bypass Cloudflare's anti-bot page"
-HOMEPAGE="
- https://github.com/VeNoMouS/cloudscraper/
- https://pypi.org/project/cloudscraper/
-"
-SRC_URI="
- https://github.com/VeNoMouS/cloudscraper/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="AGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64"
-
-RDEPEND="
- dev-python/pyparsing[${PYTHON_USEDEP}]
- dev-python/requests-toolbelt[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/js2py[${PYTHON_USEDEP}]
- dev-python/pytest-forked[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- net-libs/nodejs
- )
-"
-
-# These tests fail for no understanadble reason
-EPYTEST_DESELECT=(
- "tests/test_cloudscraper.py::TestCloudScraper::test_bad_interpreter_js_challenge1_16_05_2020"
- "tests/test_cloudscraper.py::TestCloudScraper::test_bad_solve_js_challenge1_16_05_2020"
- "tests/test_cloudscraper.py::TestCloudScraper::test_Captcha_challenge_12_12_2019"
- "tests/test_cloudscraper.py::TestCloudScraper::test_reCaptcha_providers"
-)
-
-distutils_enable_tests pytest
-
-pkg_postinst() {
- optfeature "brotli decompresssion support" "dev-python/brotlipy"
-
- optfeature "js2py interpreter support" "dev-python/js2py"
- optfeature "node.js interpreter support" "net-libs/nodejs"
-}