summaryrefslogtreecommitdiff
path: root/dev-python/clint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /dev-python/clint
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'dev-python/clint')
-rw-r--r--dev-python/clint/Manifest3
-rw-r--r--dev-python/clint/clint-0.5.1-r1.ebuild41
-rw-r--r--dev-python/clint/clint-0.5.1.ebuild2
3 files changed, 44 insertions, 2 deletions
diff --git a/dev-python/clint/Manifest b/dev-python/clint/Manifest
index d405640d53a6..967a33106205 100644
--- a/dev-python/clint/Manifest
+++ b/dev-python/clint/Manifest
@@ -1,3 +1,4 @@
DIST clint-0.5.1.tar.gz 81140 BLAKE2B 5b42e7d46321f0416d3ffb51edf66c53476d3e4a211e971f36cab54a412f6b0f0ec26486c2b95871956ab09e7e4adf68e8329dd7e9e3c7ed1adb3f8a0dd2a728 SHA512 3ad8bfc587acb1322c7d7c3e73756a07c98f3b4215a3d4dc409b5a2067bc70dce2dd98d19250b8122b319b7bcf5e2859251de2829780345de06f93b35447c4e8
-EBUILD clint-0.5.1.ebuild 946 BLAKE2B 638d1e154a0dfefdfd8e7be29c9e06959bdf6fa4910e5d26ea88f4dfc6ca54ef538a11a16dafe0e030f731c1bde72dfbcaa9e86131cabdbb760ec64e061538e3 SHA512 27a4c3c4c70fc393bf8290aea84ffbf01d5d7a992ecba28a5862f6c44c4890c37d2df72aeee85d3062293f35738f9448ba7b2b74d76e37d34c931a870e4ae78e
+EBUILD clint-0.5.1-r1.ebuild 951 BLAKE2B e053b08e02cd6a38a1f2ebc58291632c54399ad64dcc3dc4abc34c9ebd8d6f4c91c7fe4a2f15cdbcb997e3341c889c57061a1aff4d060c9b119de3254db0a8cb SHA512 adcacd3a4dcc0d3b8fd034597aa22c22a4e9c7e5d9bbe1f7b8968e112bacee18fc593a6802895e4b83f1bc8752cb2a2cdd4e1da0cbd80727c4925ea2626cf2a7
+EBUILD clint-0.5.1.ebuild 950 BLAKE2B ceca0d23d464abb06f3e8bc111033fc32629be61871c1ac58d0aa2ddff79d999b353fa5f7622dcc533f80e87e04a43e095a54c6109446b96bbe92d4834adf068 SHA512 af0ec1ee715c3d6ae902d807f541c1a2bafac90a7d7b655737aa6a357cf63657c57e158cc29a09e39e2ce2beeffbed9f1b6cf89fb676ac5ced0581c8201b7711
MISC metadata.xml 248 BLAKE2B 886e9928c5735483e1b88968c7c68b328965d8b77022184e2428115042bfa146439a44a5b3b6ae1c813fc9626617bc5158d0be4d0c173594dc93efa84f1c2268 SHA512 28daaa3233c61835448e78dfcf4381cbb1d6789f0fc16b309aa9317d36f81754d1757ba5d6be5b6b6209fad9921708619b4e92011d91c879eddc440a819fbbdb
diff --git a/dev-python/clint/clint-0.5.1-r1.ebuild b/dev-python/clint/clint-0.5.1-r1.ebuild
new file mode 100644
index 000000000000..f416abd9d86e
--- /dev/null
+++ b/dev-python/clint/clint-0.5.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python Command-line Application Tools"
+HOMEPAGE="https://github.com/kennethreitz/clint"
+SRC_URI="https://github.com/kennethreitz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND="dev-python/args[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/clint/clint-0.5.1.ebuild b/dev-python/clint/clint-0.5.1.ebuild
index 739947e2fbb6..dcb9650b052e 100644
--- a/dev-python/clint/clint-0.5.1.ebuild
+++ b/dev-python/clint/clint-0.5.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
inherit distutils-r1 vcs-snapshot